Bug 274311 - WLAN using rt2500pci fails with kernel-2.6.22.5-71.fc7
WLAN using rt2500pci fails with kernel-2.6.22.5-71.fc7
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-01 23:46 EDT by Rob K
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.22.7-85.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-28 10:14:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg for successful wifi connection (25.80 KB, application/octet-stream)
2007-09-01 23:46 EDT, Rob K
no flags Details
dmesg for unsuccessful wifi connection (26.55 KB, application/octet-stream)
2007-09-01 23:48 EDT, Rob K
no flags Details

  None (edit)
Description Rob K 2007-09-01 23:46:49 EDT
Description of problem:

NetworkManager times out when using kernel-2.6.22.5-71.fc7.
Works fine with kernel-2.6.22.2-57.fc7

If this is actually a NetworkManager issue please reassign as needed.

dmesg show:

wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:19:db:09:bd:ab
wlan0: RX authentication from 00:19:db:09:bd:ab (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:19:db:09:bd:ab
wlan0: RX AssocResp from 00:19:db:09:bd:ab (capab=0x411 status=0 aid=1)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: RX WEP frame, but no key set
wlan0: RX WEP frame, but no key set
wlan0: RX WEP frame, but no key set
wlan0: RX WEP frame, but no key set
wlan0: RX WEP frame, but no key set
wlan0: RX WEP frame, but no key set
wlan0: RX WEP frame, but no key set
wlan0: RX WEP frame, but no key set
wlan0: RX WEP frame, but no key set
wlan0: RX WEP frame, but no key set
printk: 3 messages suppressed.
wlan0: RX WEP frame, but no key set
wlan0: no IPv6 routers present
printk: 2 messages suppressed.
wlan0: RX WEP frame, but no key set
wlan0: RX WEP frame, but no key set
wlan0: RX WEP frame, but no key set
wlan0: RX WEP frame, but no key set
wlan0: RX WEP frame, but no key set
wlan0: RX WEP frame, but no key set
wlan0: RX WEP frame, but no key set
wlan0: deauthenticate(reason=3)
wlan0: RX WEP frame, but no key set

How reproducible:

Every time

Steps to Reproduce:
1. Install kernel-2.6.22.5-71.fc7
2. Reboot
3. Watch wifi fail
  
Actual results:

Wifi fails to get an IP address

Expected results:
 
Successful connection

Additional info:
Comment 1 Rob K 2007-09-01 23:46:49 EDT
Created attachment 184751 [details]
dmesg for successful wifi connection
Comment 2 Rob K 2007-09-01 23:48:38 EDT
Created attachment 184761 [details]
dmesg for unsuccessful wifi connection
Comment 4 Christopher Brown 2007-09-13 08:12:28 EDT
Looks like the latest commit broke it.

Further reading...

http://rt2x00.serialmonkey.com/phpBB2/viewtopic.php?t=4212
http://rt2x00.serialmonkey.com/phpBB2/viewtopic.php?t=4233
http://git.kernel.org/?p=linux/kernel/git/ivd/rt2x00.git;a=commitdiff;h=3980d341b7bae78f511f8b5ca9fbdb8ad42c1aff

It is still strange that the kernel update broke it as I can't see that commit
in the kernel.org kernel 2.6.22 updates. Perhaps fedora is carrying it...
Comment 5 Mostafa Afgani 2007-09-13 19:15:31 EDT
I can verify that the problem still persists in 2.6.22.5-76.fc7
Comment 6 Rob K 2007-09-27 07:22:57 EDT
It's now working again with kernel-2.6.22.7-85.fc7.

Note You need to log in before you can comment on or make changes to this bug.