Bug 27435 - Upgrade to RPM 4.0 wipes out RPM database
Summary: Upgrade to RPM 4.0 wipes out RPM database
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: sparc Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-13 19:24 UTC by vgb
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-13 19:25:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description vgb 2001-02-13 19:24:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (X11; U; Linux 2.4.0-test8 i686)


I installed the RPM 4.0 distribution from ftp.rpm.org in the dist
directory. Problem is, as
soon as I install it the old RPM database is completely gone. rpm -qa shows
no entries.
Trying to install any more RPMs fails because it keeps complaining about
dependencies.

Yes I  did do an rpm --rebuilddb first.

This is on an otherwise standard Red Hat 6.2 Sparc install. I've seen the
same problem on LinuxPPC, using RPMs built from the SRPMS on the
same site.

The rpm.org site says this is the place to report bugs for rpm, so I'm
reporting it here.

Reproducible: Always
Steps to Reproduce:
1. Take a Sparc running Red Hat 6.2
2. get popt, db3 and rpm from ftp.rpm.org/pub/rpm/dist/rpm-4.0.x. I got the
*-6x.sparc.rpm packages
3. Install popt, db3 and rpm packages thus obtained
4. Try rpm -qa. All your package info is gone.
5. If you like try rpm --rebuilddb. Package info stays gone.
	

Actual Results:  All the package info was gone. Also the files in
/var/lib/rpm are much smaller, so it does seem like installing rpm deleted
the old database.

Expected Results:  Shouldn't have deleted my RPM databse.

I really wish someone had tested the package before releasing it. Once
would have been enough.

Comment 1 Jeff Johnson 2001-02-13 20:33:22 UTC
Your database is still there, I will send instructions in a moment.

FWIW,  you will want to upgrade to rpm-4.0.1 from
ftp://ftp.rpm.org/pub/rpm/test-4.0.1
if you wish to continue using rpm-4.0. Or go back to rpm-3.0.5, instructtions on
how
coming in a moment.


Note You need to log in before you can comment on or make changes to this bug.