Bug 274391 - pm-hibernate fails to resume, does not support LABEL= syntax for swap in /etc/fstab
pm-hibernate fails to resume, does not support LABEL= syntax for swap in /etc...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
7
All All
medium Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-02 05:00 EDT by Bill C. Riemers
Modified: 2008-06-16 22:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 22:17:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill C. Riemers 2007-09-02 05:00:29 EDT
Description of problem:

After suspend, when I attempt to resume I consistently get an error that
LABEL=swap can not by found.

However, my swap indeed has a label of swap, and correctly activates when I call
swapon -a -e, after booting.  (It does not enable during boot due to the resume
error, and the fact that selinux blocks mkswap when called from swapon.)

Version-Release number of selected component (if applicable):


How reproducible:

About 60% of the time.  The other 40% the computer resumes normally.

Steps to Reproduce:
1.  suspend to disk
2.  attempt to resume
  
Actual results:

LABEL=swap not found.  Boot normally.

Expected results:

Loads suspend information from /dev/scratch/swap and resume.



Additional info:

It doesn't seem to matter if I list my swap device as LABEL=swap, or as
/dev/scratch/swap in the /etc/fstab.  Either way, it always gives the resume
message for LABEL=swap.
Comment 1 Bill C. Riemers 2007-09-04 10:20:15 EDT
I did some investigation as to where the LABEL=swap comes from when I changed
/etc/fstab, and found the fstab file in the initrd file is used to decide where
to resume from.  I ran the following command, and then I was able to suspend to
disk and resume normally:

mkinitrd -f --force-raid-probe --force-lvm-probe --fstab=/etc/fstab \
  /boot/initrd-$(uname -r).img $(uname -r)

I am guessing the 60% of the time when resumed worked, I happen to have swap
listed as /dev/scratch/swap in /etc/fstab at the time of the last kernel update,
and the 40% when it failed I happened to have LABEL=swap in the /etc/fstab at
the time of a kernel update.

So it looks like the fundamental problem is that the resume does not support the
LABEL=swap syntax, but the mkinitrd script does not know that and uses the fstab
as-is with this syntax.

Bill
Comment 2 Till Maas 2007-12-23 19:07:50 EST
This seems to belong to the mkinitrd component, because the bug is in the
mkinitrd script. In case I am wrong and it is a pm-utils bug, please reassign it
to the pm-utils component.
Comment 3 Bug Zapper 2008-05-14 10:12:00 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2008-06-16 22:17:52 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.