Bug 274691 - Boot hangs at "Starting udev" - Related to dm-crypt/LUKS?
Summary: Boot hangs at "Starting udev" - Related to dm-crypt/LUKS?
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-02 21:00 UTC by Marc Schwartz
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 2.6.22.5-76.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 17:23:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marc Schwartz 2007-09-02 21:00:03 UTC
Description of problem:

Upon booting with kernel-2.6.22.4-65.fc7, the boot process hangs at "Starting
udev".  

This does not happen with kernel-2.6.22.1-41.fc7.

/home is encrypted with dm-crypt/LUKS.


Version-Release number of selected component (if applicable):

kernel-2.6.22.4-65.fc7


How reproducible:

Always


Steps to Reproduce:
1. Boot the system with the above kernel

  
Actual results:

Boot hangs at "Starting udev"


Expected results:

Complete boot


Additional info:

NO messages for the boot with 4-65 appear in /var/log/messages at all. Messages
for the prior boot with 1-41 and the subsequent boot for 1-41 are in the log.

Comment 1 Chuck Ebbert 2007-09-04 23:18:55 UTC
Multiple patches against dm went into 2.6.22.2. Will try to narrow the list down
somehow...


Comment 2 Marc Schwartz 2007-09-05 03:29:06 UTC
Chuck,

Some additional data for you:

1. The udev update today to udev-113-12.fc7 did not make a difference.

2. I commented out /home in BOTH /etc/crypttab and in /etc/fstab and it did not
make a difference.  I did not however comment out the entry for the swap
partition in both files, which is encrypted on a per boot basis using:

  swap /dev/sda8 /dev/urandom swap,cipher=aes-cbc-essiv:sha256

which I realized that I did not mention above.

If there is other information that would be helpful to you here, let me know.


Comment 3 Marc Schwartz 2007-09-05 04:16:04 UTC
Chuck, a quick follow up. I commented out the two entries for the swap partition
as well and that made no difference either.

So I am not sure if this still leaves open the possibility of dm-crypt/LUKS
being the source of the problem or not.  There may be more subtle things in play
here.

It just seems logical as I have not seen other similar booting related problems
attributed to this kernel and considered that this might be somewhat unique to
my system.




Comment 4 Marc Schwartz 2007-09-13 03:31:21 UTC
Chuck, another follow up.

With today's kernel update to kernel-2.6.22.5-76.fc7, I can boot without a hang.

Thus, whatever the issue was with kernel-2.6.22.4-65.fc7, it appears to be
resolved in this new release.

If that helps narrow down the possible issues, let me know.

If not, given that the issue is now resolved, we can perhaps close this report
and leave it to posterity.

Thanks.


Comment 5 Chuck Ebbert 2007-09-13 17:23:38 UTC
No time to investigate further, closing as fixed...



Note You need to log in before you can comment on or make changes to this bug.