Bug 274711 - iscsi support on the installer
iscsi support on the installer
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
All All
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-02 17:46 EDT by Kostas Georgiou
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-08 21:06:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
more typos (984 bytes, patch)
2007-09-02 17:46 EDT, Kostas Georgiou
no flags Details | Diff

  None (edit)
Description Kostas Georgiou 2007-09-02 17:46:33 EDT
Another small fix for iscsi to fix the following error:
Traceback (most recent call first):
  File "/usr/lib/anaconda/iscsi.py", line 117, in login
    if _login(node, portal):
  File "/usr/lib/anaconda/iscsi.py", line 233, in addTarget
    if not t.login():
  File "/usr/lib/anaconda/iw/autopart_type.py", line 180, in addIscsiDrive
    self.anaconda.id.iscsi.addTarget(ip, port, user, pw, self.intf)
  File "/usr/lib/anaconda/iw/autopart_type.py", line 232, in addDrive
    rc = self.addIscsiDrive()
NameError: global name 'portal' is not defined
Comment 1 Kostas Georgiou 2007-09-02 17:46:33 EDT
Created attachment 184901 [details]
more typos
Comment 2 Kostas Georgiou 2007-09-02 18:10:53 EDT
Note that the patch is against F7 since rahide doesn't work under xen for me at
the moment (no network).

Unfortunately this isn't enough to get iscsi running in the installer. iscsid
fails to work because the crc32p,libcrc32p modules aren't available (similar to
#208607).

Downloading and insmoding crc32p,libcrc32p in %pre gets things going but for
some strange reason that I can not begin to understand *some* partitions
dissapear after swap gets enabled (/sys/block/sda/ only has sda2 for example)
and the installation fails :(

RHEL5 works fine with the same iscsi target (scsi-target-utils from rawhide) so
it's not the target as far as I can tell.

Comment 3 Kostas Georgiou 2007-09-08 21:06:34 EDT
Closing since rawhide has been changed quite a bit and there is no point fixing
the F7 bugs. I'll open new bugs with the issues in current rawhide.

Note You need to log in before you can comment on or make changes to this bug.