Bug 27490 - Conflicting libkdefakes requirements
Conflicting libkdefakes requirements
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kdelibs (Show other bugs)
1.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-13 21:33 EST by roystgnr
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-14 01:11:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description roystgnr 2001-02-13 21:33:04 EST
After grabbing updated kde binary i386 packages from
ftp://rawhide.redhat.com/pub/rawhide/i386/RedHat/RPMS/ (at 19:00 CST, Feb.
13), I found myself unable to install them because of missing dependencies.

The following commands should illustrate the error:

[roystgnr@mycroft kde]$ rpm -qRp kdeutils-2.0.20010122-1.i386.rpm | grep
kdefakes
libkdefakes.so.0  
[roystgnr@mycroft kde]$ rpm -q --provides -p
kdelibs-2.0.20010205-1.i386.rpm | grep kdefakes
libkdefakes.so.3
Comment 1 roystgnr 2001-02-14 01:11:34 EST
The package kdegraphics-2.0.20010122-1.i386.rpm from rawhide shows the same
problem.  Uninstalling kdeutils and kdegraphics from fisher, installing kdelibs
and kdelibs-devel from rawhide, then recompiling kdeutils and kdegraphics from
rawhide .src.rpm packages fixes the problem.
Comment 2 Bernhard Rosenkraenzer 2001-02-14 13:12:51 EST
libkdefakes.0 should never have been part of the kdelibs package; the 
requirement is no longer there in kdeutils-2.0.20010212-1 and 
kdegraphics-2.0.20010206.

Comment 3 Sammy 2001-02-26 11:04:34 EST
But it is still there in kdebindings packages for Feb.22 rawhide....I
could not install these packages since they conflicted with the rest.

Note You need to log in before you can comment on or make changes to this bug.