Bug 27493 - anaconda crashes when attempting kickstart via nfs
anaconda crashes when attempting kickstart via nfs
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-02-13 22:37 EST by Philip J. Hollenback
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-02-27 18:53:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
sample kickstart config file (864 bytes, text/plain)
2001-02-14 19:47 EST, Philip J. Hollenback
no flags Details

  None (edit)
Description Philip J. Hollenback 2001-02-13 22:37:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.18 i686)

When I try to start a kickstart install off the rh62 install cd with 'linux
ks' at the lilo prompt, anaconda dies with a stack trace indicating
"--kickstart: missing argument"

Reproducible: Always
Steps to Reproduce:
1.boot rh62 install cd
2.type 'linux ks' at the lilo prompt
3.anaconda dies

Actual Results:  A stack trace along these lines:

file "/usr/bin/anaconda" line 45 in ? [ "gui" "text" ... ]
file /usr/lib/anaconda/isys.py line 198 in getopt
return apply (_iss.getopt.args)
TypeError: bad argument --kickstart: missing argument

Expected Results:  system starts a kickstart install, queries my dhcp
server for an address, and retrieves the kickstart config file from my nfs

I've verified with a network sniffer that the install doesn't get as far as
requesting a dhcp address or making an nfs mount.

It seems like anaconda expects something after 'ks' on the kernel load
line, but the docs indicate that 'ks' is sufficient.

I've also tried an explicit kickstart via nfs with the lilo line

'linux ks=nfs:'

which causes the installer to not do a kickstart install at all, and
instead do a manual install.
Comment 1 Michael Fulbright 2001-02-14 12:44:48 EST
Brock do you recall any 6.2 related ks issues with NFS?
Comment 2 Brock Organ 2001-02-14 17:16:22 EST
could you supply the kickstart file that fails for you?  We'll try to reproduce
the problem here in our test lab ...
Comment 3 Philip J. Hollenback 2001-02-14 19:47:56 EST
Created attachment 10060 [details]
sample kickstart config file
Comment 4 Philip J. Hollenback 2001-02-14 19:50:07 EST
I've atached the kickstart config file I'm using, but note that this file never
gets read - anaconda dies before it gets a dhcp address or mounts the nfs
directory where this file resides.

I've tried kickstarting by placing this file on an existing hd partition, and it
does work that way.
Comment 5 Michael Fulbright 2001-02-27 18:53:11 EST
When you try the NFS ks and it fails, look on VC3 (cntl-alt-f3) for any nfs/ks
related messages and let us know what they say.
Comment 6 Michael Fulbright 2001-04-02 16:00:38 EDT
Closing due to inactivity - please reopen if you have anything to add to the bug

Note You need to log in before you can comment on or make changes to this bug.