Bug 274931 - Got error " signing RPMs
Got error " signing RPMs
Status: CLOSED DUPLICATE of bug 274941
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-03 03:44 EDT by Ashish Shukla
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-03 09:18:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ashish Shukla 2007-09-03 03:44:40 EDT
Description of problem:
Unable to sign any RPMs with GPG key.

Version-Release number of selected component (if applicable):
gnupg2-2.0.5.x86_64
gnupg-1.4.7.x86_64
rpm-4.4.2.1.x86_64


How reproducible:
Reproducible every time.

Steps to Reproduce:
1. Download any RPM. e.g.

[wahjava@chatteau ~]$ wget
http://wahjava.googlepages.com/apt-cacher-1.5.3-1fc6.noarch.rpm
--13:10:15--  http://wahjava.googlepages.com/apt-cacher-1.5.3-1fc6.noarch.rpm
           => `apt-cacher-1.5.3-1fc6.noarch.rpm'
Resolving wahjava.googlepages.com... 72.14.203.118
Connecting to wahjava.googlepages.com|72.14.203.118|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 59,990 (59K) [application/octet-stream]

100%[===============================================================>] 59,990  
     17.86K/s    ETA 00:00

13:10:21 (17.81 KB/s) - `apt-cacher-1.5.3-1fc6.noarch.rpm' saved [59990/59990]

2. Sign it with "rpm --addsign" .

[wahjava@chatteau ~]$ rpm --addsign apt-cacher-1.5.3-1fc6.noarch.rpm 
Enter pass phrase: 
Pass phrase is good.
apt-cacher-1.5.3-1fc6.noarch.rpm:
gpg: WARNING: standard input reopened
gpg: skipped "Ashish Shukla (आशीष शुक्ल) <wahjava@gmail.com>":
secret key not available
gpg: signing failed: secret key not available
error: gpg exec failed (2)

Actual results:

Got error 

Expected results:


Additional info:
Comment 1 Panu Matilainen 2007-09-03 09:18:51 EDT

*** This bug has been marked as a duplicate of 274941 ***

Note You need to log in before you can comment on or make changes to this bug.