Bug 2752 - /etc/ntp.conf apparently specifies incorrect stratum
/etc/ntp.conf apparently specifies incorrect stratum
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: xntp3 (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-11 21:41 EDT by dfm
Modified: 2015-01-07 18:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-12 06:56:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dfm 1999-05-11 21:41:52 EDT
It appears that the ntp.conf file in the xntp3 package
shipped with RH 6.0 contains a stray character. In previous
versions of Red Hat, the file read, in part,

fudge   127.127.1.0 stratum 0

Now, however, it reads:

fudge   127.127.1.0 stratum 10

Nonetheless, the comment block above this line continues to
speak of using stratum 0. I suspect the new version of the
file to stem from a typo.

If I'm wrong, the comment should probably be updated to
reflect (and perhaps explain) the change.
Comment 1 Jeff Johnson 1999-05-12 06:56:59 EDT
The change was made so that machines without a reference clock
did not inadvertantly start honking NTP at stratum 0. The comment,
not the configuration, is incorrect.

In order to configure and use xntp3 correctly, see the URL
http://www.cis.udel.edu/~ntp. Basically you will need to find
a reference clock server that will be added to ntp.conf as
	server	your_reference_clock_server

Red Hat can't supply a default refernce clock server in ntp.conf
because of the number of installed Red Hat systems.

Note You need to log in before you can comment on or make changes to this bug.