Bug 275461 - dhcp hangs without ethernet
dhcp hangs without ethernet
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
7
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-03 14:04 EDT by Romuald Ireneus 'Scibor-Marchocki
Modified: 2014-03-16 23:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-06 14:21:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Romuald Ireneus 'Scibor-Marchocki 2007-09-03 14:04:40 EDT
Description of problem: during the boot sequence, on the penultimate step, it
correctly reports that the ethernet is not available.  It suggests that I check
the cable.  Good.
On the next step, it broadcasts a request for a dhcp server to provide an IP
address.  It hangs.  Duh?
It should have remembered that there is no cable connected and hence skip any
attempt at connection.



Version-Release number of selected component (if applicable):
Fedora 7


How reproducible:
Install with Internet cable.
Shut down.
Disconnect cable.
Attempt to boot.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Hangs.

Expected results:
Should skip attempt to obtain IP address when there is no connection.

Additional info:
Comment 1 Adam Jackson 2007-09-04 10:45:11 EDT
That's certainly an icky bug, but it's nothing to do with bootchart.  Shifting
the blame to anaconda.
Comment 2 Bill Nottingham 2007-09-04 11:24:52 EDT
Do you have multiple network devices (wired and wireless?)
Comment 3 Romuald Ireneus 'Scibor-Marchocki 2007-09-04 12:14:29 EDT
Aye, forsooth.  My laptop has both a wired and a wireless network capability.  
However, depending on where I use it, I have only one or the other -- not both 
at once.
I istalled Fedora 7 without any problems, while the notebook was attached with 
the wired connection.  I rebooted several times, just to check-out the boot 
process.
Then, when I took the notebook to where only a wireless signal is available, 
the test for the wire connection correctly failed and helpfully suggested that 
I should check the Internet connection.
The next step was an attempt to log-on to a dhcp server, which hung.  Duh?
Obviousely, this step should have been skipped in view of the result of the 
previous step.
Finally, there should be an opportunity to configure the wireless connection.  
It has to be possible to do so without an existing connection to the Internet.  
Remember, I never have both wired and wireless at the same time.
Has this additional description helped you, Bill?
If you so desire, you may e-mail me directly at rism@rism.com or if you provide 
a land-line telephone number, I will call you (at no expense to you).
Anon,
    Romuald
Comment 4 Bill Nottingham 2007-09-04 12:30:24 EDT
When it was checking for a DHCP address, it was almost certainly checking for it
on the wireless link - does it list a different device name?
Comment 5 Romuald Ireneus 'Scibor-Marchocki 2007-09-05 09:00:50 EDT
Nay not.  It went directly from the (correct) failure of the probe for a wired 
connection to the attempt to connect to a dhcp server.  It did NOT show an 
attempt to find a wireless connection.
And, once it attempted to connect to a dhcp host, it did not display anything 
more -- it just hung.
Besides, the wireless system has a security log-in requirement.  The Fedora 7 
would have had to request that I enter the necessary credentials, before the 
wireless connection could be established.
What I would expect is for the Anaconda to boot-up WITHOUT any network 
connection.  Then, when the whole system is running -- including the user 
interface --, I would go to the relevant network control program to configure 
the wireless connection.  Finally, I would initiate an attempt to connect 
wirelessly to the Internet.
A eireless connection does not just happen by itself.  It requires user 
intervention to autenticate the client notebook computer to the wireless 
hotspot, before the hotspot will allow the connection to proceed.
I would presume that this process is too complicated for Anaconda to perform.  
Instead, Anaconda should just let the Fedora boot-up without any network 
connection.  Then when the whole system is up and running, let the user 
initiate a manual connection to a wireless network, if such a network is 
available.  There very well might not be any wireless available.
Gramercy for your interest in this problem and your quick involvement.
Anon,
   Romuald
Comment 6 Bill Nottingham 2007-09-05 14:05:25 EDT
Can you attach all the /etc/sysconfig/network-scripts/ifcfg-* files?
Comment 7 Romuald Ireneus 'Scibor-Marchocki 2007-09-06 13:47:41 EDT
Gramercy, Bill Nottingham.  You have fixed it!
Each time that I had been connected on the wired (ethernet) networ, there were 
updates automatically downloaded and installed.
Yesterday, I noticed a change in AnacondA.  So, this morning, I attempted to 
boot Fedora here -- where only the WIRELESS network is available.  
Anaconda "failed" on both the etho and wlan0, but it allowed the boot to 
proceed.  When gnome UI came-up, I loged into the wireless network (after 
supplying the appropriate password).  It works very well wireless!!!
Just to make sure, I restarted:  OK.
I hybernated and started it up:  OK.
Once again, Gramercy Bill.  Excellent.
Anon,
    Romuald
Comment 8 Bill Nottingham 2007-09-06 14:21:33 EDT
OK, closing for now. I've been unable to reproduce the hang here.

Note You need to log in before you can comment on or make changes to this bug.