Bug 275541 - stricter Requires: needed
Summary: stricter Requires: needed
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: poppler
Version: 11
Hardware: All
OS: All
medium
low
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 226305
TreeView+ depends on / blocked
 
Reported: 2007-09-03 20:16 UTC by Moritz Barsnick
Modified: 2009-06-20 14:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-06-20 14:09:29 UTC


Attachments (Terms of Use)

Description Moritz Barsnick 2007-09-03 20:16:14 UTC
Description of problem:
poppler's requirements and build requirements need to be specified more 
strictly.

Version-Release number of selected component (if applicable):
0.5.91-2.fc8

How reproducible:
always, by pure reading of source and changelog

Additional info:
poppler's configure.ac specifically checks for:
cairo >= 1.4
gdk-2.0 >= 2.4.0 (which is part of gtk-2.0)
glib-2.0 >= 2.6
libjpeg

So the SPEC file's
BuildRequires: gtk2-devel
BuildRequires: cairo-devel
BuildRequires: qt-devel

should probably be
BuildRequires: glib2-devel >= 2.6
BuildRequires: gtk2-devel >= 2.4.0
BuildRequires: cairo-devel >= 1.4
BuildRequires: qt-devel
BuildRequires: libjpeg-devel
Requires: glib2 >= 2.6
Requires: gtk2 >= 2.4.0
Requires: cairo >= 1.4

(Although of course it's up to you to say that the Requires: are obsolete, 
because nothing that low will be encountered on supported distributions.)

Comment 1 Bug Zapper 2008-05-14 03:10:45 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Orcan Ogetbil 2009-05-17 19:21:08 UTC
Ping?

It's been 20 months since this is reported. Is this so hard to fix?

Comment 3 Moritz Barsnick 2009-05-18 11:21:07 UTC
Since I'm the original poster of this ticket, let me take the liberty to:
- nudge it to RawHide,
- update the facts.

poppler's configure.ac specifically checks for:
fontconfig >= 2.0.0
cairo >= 1.4
gdk-2.0 >= 2.8.0 (which is part of gtk-2.0)
glib-2.0 >= 2.6
Qt4 >= 4.1.0
libjpeg

So the SPEC file's
BuildRequires: gtk2-devel
BuildRequires: cairo-devel
BuildRequires: qt3-devel
BuildRequires: qt4-devel

should probably be
BuildRequires: glib2-devel >= 2.6
BuildRequires: gtk2-devel >= 2.8.0
BuildRequires: cairo-devel >= 1.4
BuildRequires: qt3-devel
BuildRequires: qt4-devel >= 4.1.0
BuildRequires: libjpeg-devel
Requires: glib2 >= 2.6
Requires: gtk2 >= 2.8.0
Requires: cairo >= 1.4
Requires: qt4 >= 4.1.0

fontconfig-devel >= 2.0.0 is already pulled in by cairo, it seems.

Also, building against libopenjpeg would be great, but there's another ticket open against openjpeg (#484887) which would aid in that. I do have a patch for poppler though. ;-)

Comment 4 Bug Zapper 2009-06-09 09:17:40 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 5 Rex Dieter 2009-06-19 17:16:24 UTC
It works as-is for each cvs branch and release of fedora.

What's the use-case here? so folks can grab/rebuild random rawhide pkgs on build on/for previous releases?

Comment 6 Moritz Barsnick 2009-06-20 14:03:40 UTC
> What's the use-case here? so folks can grab/rebuild random rawhide
> pkgs on build on/for previous releases?

I would have said so, yes. It saves people a lot of hassle when e.g. trying to build newer versions of tools from e.g. Rawhide for older releases. (E.g. I have kept around an FC6(!) as well as an F8 lab system at work for various reasons, and sometimes find myself fetching newer packages from F10 or Rawhide for the sake of featues or security.)

OTOH, the Fedora Packaging guidelines (https://fedoraproject.org/wiki/Packaging/Guidelines#Requires) say:

"First, if the lowest possible requirement is so old that nobody has a version older than that installed on any target distribution release, there's no need to include the version in the dependency at all. In that case we know the available software is new enough."

If this is fulfilled, I guess it's fine by me, though I feel more comfortable with correct explicits, as mentioned above.

Feel free to close the ticket. Thanks anyway!

Comment 7 Rex Dieter 2009-06-20 14:09:29 UTC
Understandable, I'm working on poppler packaging at the moment, and will consider adding versioned BR's where it makes sense, by extra explicit Requires likely won't make the cut.


Note You need to log in before you can comment on or make changes to this bug.