Bug 275541 - stricter Requires: needed
stricter Requires: needed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: poppler (Show other bugs)
11
All All
medium Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 226305
  Show dependency treegraph
 
Reported: 2007-09-03 16:16 EDT by Moritz Barsnick
Modified: 2009-06-20 10:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-20 10:09:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moritz Barsnick 2007-09-03 16:16:14 EDT
Description of problem:
poppler's requirements and build requirements need to be specified more 
strictly.

Version-Release number of selected component (if applicable):
0.5.91-2.fc8

How reproducible:
always, by pure reading of source and changelog

Additional info:
poppler's configure.ac specifically checks for:
cairo >= 1.4
gdk-2.0 >= 2.4.0 (which is part of gtk-2.0)
glib-2.0 >= 2.6
libjpeg

So the SPEC file's
BuildRequires: gtk2-devel
BuildRequires: cairo-devel
BuildRequires: qt-devel

should probably be
BuildRequires: glib2-devel >= 2.6
BuildRequires: gtk2-devel >= 2.4.0
BuildRequires: cairo-devel >= 1.4
BuildRequires: qt-devel
BuildRequires: libjpeg-devel
Requires: glib2 >= 2.6
Requires: gtk2 >= 2.4.0
Requires: cairo >= 1.4

(Although of course it's up to you to say that the Requires: are obsolete, 
because nothing that low will be encountered on supported distributions.)
Comment 1 Bug Zapper 2008-05-13 23:10:45 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Orcan Ogetbil 2009-05-17 15:21:08 EDT
Ping?

It's been 20 months since this is reported. Is this so hard to fix?
Comment 3 Moritz Barsnick 2009-05-18 07:21:07 EDT
Since I'm the original poster of this ticket, let me take the liberty to:
- nudge it to RawHide,
- update the facts.

poppler's configure.ac specifically checks for:
fontconfig >= 2.0.0
cairo >= 1.4
gdk-2.0 >= 2.8.0 (which is part of gtk-2.0)
glib-2.0 >= 2.6
Qt4 >= 4.1.0
libjpeg

So the SPEC file's
BuildRequires: gtk2-devel
BuildRequires: cairo-devel
BuildRequires: qt3-devel
BuildRequires: qt4-devel

should probably be
BuildRequires: glib2-devel >= 2.6
BuildRequires: gtk2-devel >= 2.8.0
BuildRequires: cairo-devel >= 1.4
BuildRequires: qt3-devel
BuildRequires: qt4-devel >= 4.1.0
BuildRequires: libjpeg-devel
Requires: glib2 >= 2.6
Requires: gtk2 >= 2.8.0
Requires: cairo >= 1.4
Requires: qt4 >= 4.1.0

fontconfig-devel >= 2.0.0 is already pulled in by cairo, it seems.

Also, building against libopenjpeg would be great, but there's another ticket open against openjpeg (#484887) which would aid in that. I do have a patch for poppler though. ;-)
Comment 4 Bug Zapper 2009-06-09 05:17:40 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Rex Dieter 2009-06-19 13:16:24 EDT
It works as-is for each cvs branch and release of fedora.

What's the use-case here? so folks can grab/rebuild random rawhide pkgs on build on/for previous releases?
Comment 6 Moritz Barsnick 2009-06-20 10:03:40 EDT
> What's the use-case here? so folks can grab/rebuild random rawhide
> pkgs on build on/for previous releases?

I would have said so, yes. It saves people a lot of hassle when e.g. trying to build newer versions of tools from e.g. Rawhide for older releases. (E.g. I have kept around an FC6(!) as well as an F8 lab system at work for various reasons, and sometimes find myself fetching newer packages from F10 or Rawhide for the sake of featues or security.)

OTOH, the Fedora Packaging guidelines (https://fedoraproject.org/wiki/Packaging/Guidelines#Requires) say:

"First, if the lowest possible requirement is so old that nobody has a version older than that installed on any target distribution release, there's no need to include the version in the dependency at all. In that case we know the available software is new enough."

If this is fulfilled, I guess it's fine by me, though I feel more comfortable with correct explicits, as mentioned above.

Feel free to close the ticket. Thanks anyway!
Comment 7 Rex Dieter 2009-06-20 10:09:29 EDT
Understandable, I'm working on poppler packaging at the moment, and will consider adding versioned BR's where it makes sense, by extra explicit Requires likely won't make the cut.

Note You need to log in before you can comment on or make changes to this bug.