Bug 275611 - Sound has not worked on my system since Fedora Core 5
Sound has not worked on my system since Fedora Core 5
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
7
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-03 17:34 EDT by Karl Guenther
Modified: 2008-02-24 10:32 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-22 05:45:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsconfig.log file created by sound detection module (45.41 KB, text/plain)
2007-09-03 17:34 EDT, Karl Guenther
no flags Details

  None (edit)
Description Karl Guenther 2007-09-03 17:34:42 EDT
Description of problem:  I have a Dell 8300 with a emu10k1x sound card.  The
sound works just fine on a FC5 partition buy not on a Fedora 7 partition with
the latest maintenance applied to all software.


Version-Release number of selected component (if applicable):


How reproducible:  Try to use sound detection component or other sound software
and sound will not come out of speaker on Fedora 7.  If I boot the system to a
FC5 partition sound will play just fine.


Steps to Reproduce:
1.  Select sound detection
2.  Set to back plugin for speaker wire, set to repeat, and press play button.  
3.
  
Actual results:

No sound plays

Expected results:

Sound to play


Additional info:  Here is the scsrun.log and I have attached the scsconfig.log:

------- System Config Soundcard Log --------
Mon Sep  3 16:27:37 CDT 2007

Playing WAVE '/usr/share/system-config-soundcard/sound-sample.wav' : Signed 16
bit Little Endian, Rate 44100 Hz, Stereo
Aborted by signal Terminated...
Running from command-line...
Comment 1 Karl Guenther 2007-09-03 17:34:42 EDT
Created attachment 185441 [details]
scsconfig.log file created by sound detection module
Comment 2 Callum Lerwick 2007-09-03 18:52:34 EDT
Not sure why this is filed under "soundtracker", reassigning to
"system-config-soundcard" :)
Comment 3 Martin Stransky 2007-09-10 05:49:36 EDT
Do you hear anything if you run "aplay -D plughw:0,0
/usr/share/sounds/phone.wav" in terminal?
Comment 4 Karl Guenther 2007-09-10 06:15:08 EDT
No I don't

[karl@localhost ~]$ aplay -D plughw:0,0 /usr/share/sounds/phone.wav
Playing WAVE '/usr/share/sounds/phone.wav' : Signed 16 bit Little Endian, Rate
44100 Hz, Stereo
[karl@localhost ~]$
[karl@localhost ~]$
Comment 5 Martin Stransky 2007-09-10 07:07:34 EDT
Cay you check the "alsamixer" utility and try to enable/unmute some channels.

It looks like a problem in drivers/kernel. If that alsamixer doesn't work for
you, you may report it to ALSA project (www.alsa-project.org).
Comment 6 Karl Guenther 2007-09-11 21:07:32 EDT
Thank You,

I have spent a lot of time on this.  Yes I had checked the controls in alsamixer
from root and tested different changes.  I did some additional testing and
analysis today.

I wrote down the settings in Fedora 7 and compared them to FC5.  There are
several differences.  The main one from what i can see is that FC5 has a PCM and
a PCM Out control.  Fedora 7 only has a PCM control and not PCM Out control.  I
did some searches on the net and I could not find anything relavant for a PCM
Out control missing in Alsamixer.  Should a PCM Out control be showing up in
Alsamixer on F7?

I will proceed to submit a bug to the Alsa project in the next few days.

Thank You for your help.
Comment 7 Karl Guenther 2007-09-13 21:59:03 EDT
I was hoping you would respond to the question.  Should a PCM Out control be
showing up in Alsamixer on f7?

Thank You
Comment 8 Karl Guenther 2007-09-22 20:28:41 EDT
Could you tell me what level of alsa-drivers is in Fedora 7.91 (Fedora 8 Test
Level 2).  I load it up but I still have the problem.  With updates that gave me
newer 1.0.15 levels of alsa-lib and alsa-utils.

Thank You
Comment 9 Martin Stransky 2008-02-22 05:45:12 EST
The latest available ALSA is 1.0.16. The current ALSA in F8 is 1.0.15.

Unfortunately s-c-s was removed from F9 and it's not going to be developed.
Closing as wontfix.

If you have any hardware support issue, please file it against kernel.
Comment 10 Karl Guenther 2008-02-24 01:45:43 EST
What is s-c-s?
Comment 11 Karl Guenther 2008-02-24 10:32:49 EST
OK - s-c-s means system-config-soundcard

Note You need to log in before you can comment on or make changes to this bug.