Bug 275661 - gdmlogin segfault for XDMCP on x86_64
gdmlogin segfault for XDMCP on x86_64
Status: CLOSED DUPLICATE of bug 246399
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
7
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-03 20:11 EDT by Scott Hunziker
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-05 10:37:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Hunziker 2007-09-03 20:11:27 EDT
Description of problem:
Can't log in to new F7 installation via XDMCP.  Message in /var/log/messages:

      kernel: gdmlogin[3099]: segfault at 00000000000000001c rip
00002aaab617a318 rsp 00007ffffff649410 error 4

I added debugging to log -- this happens right after

      gdm[2501]: Handling user message: 'GET_CONFIG daemon/AddGTkModules hostname:0'
      gdm[2501]: Handling user message: 'CLOSE'

Version-Release number of selected component (if applicable):
gdm-2.18.4-2.fc7.src.rpm

How reproducible:
always happens from Exceed on Windows 

Steps to Reproduce:
1.  Set Exceed for XDMCP Query of F7 machine
2.  Launch it -- silently quits with no connection
3.  See segfault message in F7 log file
  
Actual results:
no connection

Expected results:
Trying to replace an old i386 machine.  It runs FC3 with gdm-2.6.0.5-6 and works
fine with Exceed.

Additional info:
Same results, even if I set remote logins disabled.
Comment 1 Ray Strode [halfline] 2007-09-04 10:12:24 EDT
Hi, this may be a duplicate of bug 246399.  Does the work around mentioned in
the second comment of that bug report work around the problem for you? 
Comment 2 Ray Strode [halfline] 2007-09-05 10:37:07 EDT

*** This bug has been marked as a duplicate of 246399 ***

Note You need to log in before you can comment on or make changes to this bug.