Bug 27589 - Inconsistent output from rpm -q --specfile when using BuildArch:
Summary: Inconsistent output from rpm -q --specfile when using BuildArch:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 30650 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-14 09:35 UTC by Toralf
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-18 21:07:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Toralf 2001-02-14 09:35:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-22 i686)


Using BuildArch: or BuildArchitectures: tag in spec file changes the rpm
query output in the following way:
1. When the spec file contains several packages, 'rpm -q --specfile'
   lists only the name/version of the main one. Expanded names of the
   sub packages are not included like they are when "BuildArch" is not
   used.
2. 'rpm -q --queryformat "%{ARCH}"' returns "(none)" rather than the
   real build architecture.

Reproducible: Always
Steps to Reproduce:
1.Take a simple spec file containing at least one %package directive,  but
no BuildArch:
2.rpm -q --specfile <spec file name>
3.Insert 'BuildArch: noarch' in package headers.
4.Repeat 2.

Comment 1 Jeff Johnson 2001-03-05 16:31:34 UTC
*** Bug 30650 has been marked as a duplicate of this bug. ***

Comment 2 Tony Clayton 2001-04-18 21:07:46 UTC
I am having similar problems.  With 'BuildArchitecture: noarch', the ouput of 
rpm -q --changelog --specfile <file> 
returns nothing.


Comment 3 Jeff Johnson 2001-05-06 19:39:46 UTC
Fixed in rpm-4.0.3-0.15 (be careful if you upgrade, there's still known bugs for
rpm > 4.0.3-0.6, you might want to fish out the changes in build/parseSpec.c
and apply to rpm-4.0.2 if needed).


Note You need to log in before you can comment on or make changes to this bug.