Bug 275931 - AC97 sound card not detected
AC97 sound card not detected
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-09-04 06:31 EDT by Colin Brace
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-25 00:32:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
scsconfig.log (80.21 KB, text/plain)
2007-09-04 06:31 EDT, Colin Brace
no flags Details
scs screen (41.75 KB, image/png)
2007-09-16 23:31 EDT, nando carvalho
no flags Details
scs screen 1 (40.85 KB, image/png)
2007-09-16 23:32 EDT, nando carvalho
no flags Details
scs screen 1 (40.85 KB, image/png)
2007-09-16 23:32 EDT, nando carvalho
no flags Details

  None (edit)
Description Colin Brace 2007-09-04 06:31:50 EDT
Description of problem:

Previous versions of Fedora (FC3-FC6) detected the embedded AC97 sound
controller on my Asus P4 motherboard without problem but Fedora 7 does not. That
is to say, the hardware is recognized but automatic sound card detection fails.

This is the case both with the current kernel, v2.6.22.4-65.fc7, as well as the
original release kernel, v2.6.21-1.3228.fc7

I am using ALSA driver v1.0.14

------- rpm -q alsa-lib --------

------- rpm -q alsa-utils --------

How reproducible:

Steps to Reproduce:
1.  Ran sound card detection.
2.  Test Sound.

Actual Results:  No sound is heard.

Expected Results:  There should have been sound heard through the speakers.

Additional info:
Comment 1 Colin Brace 2007-09-04 06:31:50 EDT
Created attachment 186051 [details]
Comment 2 Colin Brace 2007-09-04 06:34:41 EDT
The full name of the embedded sound card is: "Intel Corporation 82801EB/ER
(ICH5/ICH5R) AC'97 Audio Controller"
Comment 3 Martin Stransky 2007-09-10 05:57:17 EDT
Please run system-config-soundcard, switch to "System" tab and select "rewrite
configuration files" and reboot your box. The USB sound device is loaded as the
first soundcard (index 0) and the AC97 fails to load then.
Comment 4 Colin Brace 2007-09-11 05:46:18 EDT
I rewrote the config files following your instructions and rebooted, but it did
not appear to make a difference; card is still not recognized.

Not sure what you mean by USB sound device. AFAIK, I don't have one attached.

Comment 5 Martin Stransky 2007-09-11 05:55:19 EDT
Can you please run system-config-soundcard and attach a screenshot of the first
and second page of that utility? 
Comment 6 Alain PECH 2007-09-11 11:47:49 EDT
I have the same pb as cb@lim.nl. As requested I run system-config-soundcard,
switch to "System" tab and select "rewrite configuration files". I reboot the
system and now it's ok.
Comment 7 nando carvalho 2007-09-16 23:31:36 EDT
Created attachment 196851 [details]
scs screen

sound card info
Comment 8 nando carvalho 2007-09-16 23:32:27 EDT
Created attachment 196861 [details]
scs screen 1
Comment 9 nando carvalho 2007-09-16 23:32:38 EDT
Created attachment 196871 [details]
scs screen 1
Comment 10 nando carvalho 2007-09-16 23:36:14 EDT
same problem as ny fellows above..run scs but still no sound..please help
Comment 11 Brian Powell 2008-04-25 00:32:09 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there have not been any
updates to the report since thirty (30) days or more since we
requested additional information, we're assuming the problem
is either no longer present in the current Fedora release, or
that there is no longer any interest in tracking the problem.

Setting status to "CLOSED INSUFFICIENT_DATA".  If you still
experience this problem after updating to our latest Fedora
release and can provide the information previously requested, 
please feel free to reopen the bug report.

Thank you in advance.

Note that maintenance for Fedora 7 will end 30 days after the GA of Fedora 9.

Note You need to log in before you can comment on or make changes to this bug.