Bug 276051 - missing libedit-devel rpm
missing libedit-devel rpm
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libedit (Show other bugs)
rawhide
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-04 07:55 EDT by John Ellson
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-04 08:49:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2007-09-04 07:55:32 EDT
Description of problem:
I'm trying to build the Io language <http://www.iolanguage.com/about/>, but its
Makefile isn't finding libedit.so    Shouldn't this be provided by a
libedit-devel rpm?

Version-Release number of selected component (if applicable):
libedit-2.10-1.20070302cvs.fc7.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Debarshi Ray 2007-09-04 08:18:10 EDT
Libedit was an orphaned package for a few months until I took it over a couple
of days back. However even though it was orphaned, it was not marked as such in
the CVS. What you are trying to use here (ibedit-2.10-1.20070302cvs.fc7) is the
libedit package that was available just before it was orphaned. I have built a
new package for Fedora 7, which is yet to be pushed to updates-testing.

For the time being just download any of the packages from
http://koji.fedoraproject.org/koji/buildinfo?buildID=17689 and let me know if it
solves your problem.
Comment 2 John Ellson 2007-09-04 08:33:33 EDT
Thanks, your libedit-devel-2.10-1.20070831cvs.fc7.x86_64.rpm provides the
missing libedit.so.   Can this be pushed into Rawhide as well?
Comment 3 Debarshi Ray 2007-09-04 08:49:48 EDT
Good. It was somehow locked for Rawhide and hence I could not build it. Once
that is resolved it will be available for Rawhide too.

I am closing this bug.

Note You need to log in before you can comment on or make changes to this bug.