Bug 27649 - rpm2html forcing sql support
rpm2html forcing sql support
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm2html (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-14 13:57 EST by edwinh
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-08 10:19:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description edwinh 2001-02-14 13:57:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-pre2 i686)


Is there a way to disable rpm2html trying to use mysql? Being forced
on always makes it not usable for many purposes.


Reproducible: Always
Steps to Reproduce:
Using rpm2html-1.5-4.i386.rpm

1. create a custom rpm2html config (just for yoor own locally installed
pkgs for example)
2. run rpm2html
3. it will die due to being unable to connect to mysql.
Comment 1 Jeff Johnson 2001-03-27 08:37:57 EST
Easiest fix is to recompile rpm2html w/o mysql support.
Comment 2 Daniel Veillard 2001-05-14 12:08:23 EDT
I will try to add a command line argument to skip the
database operations even when compiled with database support

Daniel
Comment 3 Michael Schwendt 2001-05-29 12:32:49 EDT
rpm2html: Symbol rpmTagTable' has different size in shared object,
consider re-linking

Does this hurt?

Also, is the MySQL "rpmfind" database set-up documented anywhere? I've chosen to
recompile rpm2html without MySQL to turn the package usable.
Comment 4 Daniel Veillard 2001-07-08 06:43:06 EDT
The database stuff is finally documented. It is not useful except if
you plan to build an indexed queryable base. Documentation is in CVS.

http://sources.redhat.com/cgi-bin/cvsweb.cgi/rpm2html/rpm2html-mysql-setup.txt?rev=1.1&content-type=text/x-cvsweb-markup&cvsroot=rpm2html
  
I will make sure that the default is not to build with sql support
since this is useful only to a minority of users.

Considering "Symbol rpmTagTable' has different size in shared object"in my
experience it is better to rebuild the package, yes.

Daniel
Comment 5 Jeff Johnson 2001-07-08 10:19:52 EDT
Better yet, if rpmTagTable is causing problems, consider static linking,
The cure for rpmTagTable changing size is going to be
to take it out of the rpmlib API, leaving instead a pointer
to a static table.
Comment 6 Daniel Veillard 2001-07-17 19:23:06 EDT
I just released rpm2html-1.6, it is not configured with mysql support
by default (I expect only a minority of users to need this feature and
they will need to read the associated doc anyway).
This should fix this bug,

Daniel

Note You need to log in before you can comment on or make changes to this bug.