Bug 276621 - doesn't start - unresolved symbols
Summary: doesn't start - unresolved symbols
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F8Blocker
TreeView+ depends on / blocked
 
Reported: 2007-09-04 16:28 UTC by Bill Nottingham
Modified: 2014-03-17 03:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-06 06:46:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2007-09-04 16:28:39 UTC
Description of problem:

$ oowriter  RHTimesheet-20070904.sxw 
Gtk-Message: Failed to load module "gnomebreakpad": libgnomebreakpad.so: cannot
open shared object file: No such file or directory
/usr/lib64/openoffice.org/program/swriter.bin: symbol lookup error:
/usr/lib64/openoffice.org/program/i18npool.uno.so: undefined symbol:
ublock_getCode_3_7

Version-Release number of selected component (if applicable):

openoffice.org-core-2.3.0-3.1.fc8

How reproducible:

100%

Steps to Reproduce:
1. open oowriter with a document

Comment 1 Caolan McNamara 2007-09-04 17:09:50 UTC
works for me so...

[caolan@Nom tmp]$ nm -D /usr/lib64/openoffice.org/program/i18npool.uno.so | grep
block_getCode
                 U ublock_getCode_3_7

[caolan@Nom tmp]$ ldd /usr/lib64/openoffice.org/program/i18npool.uno.so | grep icuuc
        libicuuc.so.38 => /usr/lib64/libicuuc.so.38 (0x00002aaaac079000)

[caolan@Nom tmp]$ nm -D /usr/lib64/libicuuc.so.38 | grep ublock_getCode_3_7
0000000000092280 T ublock_getCode_3_7

what do you have ?

Comment 2 Caolan McNamara 2007-09-04 17:12:39 UTC
Ah, need to rebuild against icu again, bugger.

Comment 3 Caolan McNamara 2007-09-04 18:43:27 UTC
need to rebuild to make sure can build against icedtea anyway.

Comment 4 Caolan McNamara 2007-09-06 06:46:55 UTC
openoffice.org-2.3.0-3.2 is now fine against libicu-3.8-0.2.d02.fc8 which was
the problem


Note You need to log in before you can comment on or make changes to this bug.