Bug 276731 - Bluecurve KWin theme shows pixel noise for "sticky" icon
Bluecurve KWin theme shows pixel noise for "sticky" icon
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-artwork (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-04 12:51 EDT by Kevin Kofler
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-14 07:31:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2007-09-04 12:51:21 EDT
+++ This bug was initially created as a clone of Bug #242840 +++

Description of problem:
The Bluecurve KWin theme's "sticky" ("show on all desktops") icon isn't 
displayed properly, instead some garbage pixels are being shown.

Version-Release number of selected component (if applicable):
redhat-artwork-kde-7.0.0-9.fc7

How reproducible:
Always

Steps to Reproduce:
1. Set the KWin window decoration theme to Bluecurve.
2. Enable the "sticky" icon. (AFAICT, this is the default with 
kde-settings-3.5-28.fc7.1.)
  
Actual results:
There's some random pixels not representing anything.

Expected results:
A recognizable icon should be displayed.

Additional info:
I'm willing to try to hunt this down in the source code if I'm the only one 
who still cares about Bluecurve. ;-)

-- Additional comment from kevin@tigcc.ticalc.org on 2007-06-07 20:51 EST --
So, given that I'd have to look into that for Quarticurve-kwin (the KDE 4 
port) 
anyway, I looked at the problem and found it: someone must have changed 
BASE_BUTTON_SIZE from 16 to 17 at some point, but the pixel data for the "pin" 
icons is all in 16x16. I'm currently trying to figure out the best way to fix 
it. (I have the icon itself fixed, but the masking is still not right in my 
current patch.)

-- Additional comment from kevin@tigcc.ticalc.org on 2007-06-07 21:14 EST --
Created an attachment (id=156535)
Patch to fix "show on all desktops" in Bluecurve KWin theme

So this one is the good one. Masking now works too (I had to explicitly fill
the extra row and column there). Than, can you please apply this and push this
bugfix to F7 (maybe even FC6 too) ASAP?

-- Additional comment from kevin@tigcc.ticalc.org on 2007-06-07 21:15 EST --
Created an attachment (id=156537)
Corresponding specfile patch

And here's the corresponding specfile patch.

-- Additional comment from than@redhat.com on 2007-06-12 10:40 EST --
Kevin, i have taken a look at the patch, it looks fine. But i think it's 
better only change BASE_BUTTON_SIZE to 16.

I will ask David as package maintainer to push this bugfix to F7. Thanks

-- Additional comment from kevin@tigcc.ticalc.org on 2007-06-12 11:44 EST --
The reason I did my patch this way is that 1. I didn't know why and when 
BASE_BUTTON_SIZE was changed and 2. I didn't want to change the looks except 
for fixing that bug. BASE_BUTTON_SIZE is used in a few more places.

-- Additional comment from kevin@tigcc.ticalc.org on 2007-06-18 22:15 EST --
Now that you got the KDE 3.5.7 updates out to testing, may I kindly remind you 
of this bug?

-- Additional comment from than@redhat.com on 2007-06-19 11:46 EST --
It's now fixed in redhat-artwork-7_0_0-11_fc7. I will push it into F7 update 
today. Thanks

-- Additional comment from updates@fedoraproject.org on 2007-06-19 17:36 
EST --
redhat-artwork-7.0.0-11.fc7 has been pushed to the Fedora 7 testing 
repository.  If problems still persist, please make note of it in this bug 
report.

-- Additional comment from kevin@tigcc.ticalc.org on 2007-06-21 08:52 EST --
I marked my patches obsolete because they are not what went in.

I tested the package from testing and it works fine (in fact I'm running it 
now 
without any problems).

-- Additional comment from updates@fedoraproject.org on 2007-06-27 21:54 
EST --
redhat-artwork-7.0.0-11.fc7 has been pushed to the Fedora 7 stable repository.  
If problems still persist, please make note of it in this bug report.

-- Additional comment from kevin@tigcc.ticalc.org on 2007-08-13 12:48 EST --
Can you please apply the fix to devel too (now that we're probably going to 
still ship KWin v3 in F8)?
Comment 1 Kevin Kofler 2007-09-13 00:15:35 EDT
Ping?
Comment 2 Ngo Than 2007-09-14 07:31:24 EDT
Kevin, it's now fixed in rawhide. Sorry for delay.

Note You need to log in before you can comment on or make changes to this bug.