Bug 27680 - sndconfig fails to set up AWE32 midi
sndconfig fails to set up AWE32 midi
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-14 18:00 EST by Chris Evans
Modified: 2014-03-16 22:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-18 23:15:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Evans 2001-02-14 18:00:58 EST
This is a regression from RH7.0
I have a Soundblaster AWE32 card.
The RH7.0 soundconfig was able to set up MIDI fine.
sndconfig in BETA3 fails to detect the MIDI capabilities
of my card.
There is an error reported from awe_wave.o: couldn't find
AWE32 synth (or something along those lines).
.
Looking into this, the change that broke things seems to be
ISA PNP support in the kernel driver.
.
The following insmod command fails
insmod awe_wave.o
However the following insmod command works fine
insmod awe_wave.o isapnp=0
Comment 1 Bill Nottingham 2001-02-14 21:45:21 EST
What does your /etc/modules.conf and /etc/isapnp.conf look like?
Comment 2 Chris Evans 2001-02-15 19:06:46 EST
/etc/modules.conf follows
(as we can see it is missing the isapnp=0 for awe_wave)
---
alias eth0 3c59x
alias parport_lowlevel parport_pc
alias char-major-81 bttv
alias usb-controller usb-uhci
alias sound-slot-0 sb
options sound dmabuf=1
options opl3 io=0x388
alias midi awe_wave
post-install awe_wave /bin/sfxload /etc/midi/GU11-ROM.SF2
options sb io=0x220 irq=5 dma=1 dma16=6 mpu_io=0x330
---

Ooh - I do not seem to have a /etc/isapnp.conf.
Is that bad? Should something have made one?
Comment 3 Bill Nottingham 2001-02-16 12:48:20 EST
sndconfig technically should have, if it saw the PnP card as such.

What happens if you do 'modprobe awe_wave isapnp=1', out of
curiousity?

What does /proc/isapnp look like?
Comment 4 Chris Evans 2001-02-16 17:48:02 EST
Hmm.. I don't seem to have a /proc/isapnp
I looked in the BIOS... ISAPnP disable. I turned it on, and
still no /proc/isapnp
.
If I do the insmod you ask:
..
AWE32: No ISAPnP cards found
AWE32: not detected
/lib/modules/2.4.0-0.99.11/kernel/drivers/sound/awe_wave.o: init_module: 
No such device
.
I guess this highlights the need to at least fallback on a non-ISAPnP
attempt if the ISAPnP attempt fails.
We don't want to regress from working RH7.0 functionality ;-)
Comment 5 Bill Nottingham 2001-02-16 17:54:29 EST
Dumb question. Is it an ISAPnP card?

Do you get any

isapnp:

messags when the kernel boots?
Comment 6 Chris Evans 2001-02-16 17:59:36 EST
Don't know if it's PnP. The boot messages don't think
so, but that could be because the BIOS is whacked.
Who knows.
..
isapnp: Scanning for Pnp cards...
isapnp: No Plug & Play device found
...
sb: No ISAPnP cards found, trying standard ones...
SB 4.13 detected OK (220)
Comment 7 Bill Nottingham 2001-02-16 18:01:34 EST
If/when you boot 2.2, does sndconfig probe for and find
the card automatically?  That would imply that it is PnP...
Comment 8 Chris Evans 2001-02-16 18:07:08 EST
Like I said, RH7.0 sndconfig "just works" and sets up
the digital and midi parts.

I didn't think RH7.0 bothered with ISAPnP detection? I
thought it just did "insmod awe_wave.o". This works in
RH7.0 because the 2.2 driver doesn't have any isapnp
code, just the non-isapnp detection routine.
Perhaps the 2.4 awe_wave driver needs to fallback to
non-isapnp like the plain soundblaster module seems
to?
Comment 9 Bill Nottingham 2001-02-16 18:29:51 EST
Yup, 7.0 does isapnp detection; if you don't get
the 'No PnP or PCI sound cards have ...' dialog, that assumes
it's an isapnp card.

If you rebuild the kernel and turn off the kernel ISAPNP support,
does the card suddenly show up if you run pnpdump?
Comment 10 Chris Evans 2001-02-16 18:41:31 EST
Oh hang on
In both RH7.0 and RH7.1 I get the "No ISAPnP or PCI cards detected".
.
So I manually pick AWE32/64
.
The difference is that RH7.0 then happily finds the MIDI synth, RH7.1
does not.
Looks like RH7.1 sndconfig is forgetting to use "isapnp=0" when it
_knows_ it doesn't have a PnP card.
.
Does this make sense or are we talking at right angles?
Comment 11 Bill Nottingham 2001-02-16 18:59:22 EST
Sort of. It's just there are reports of PnP cards spontaneously disappearing
between 2.2 and 2.4. :)
Comment 12 Bill Nottingham 2001-02-18 23:15:40 EST
The biggest problem with just adding isapnp=0 for non-PnP cards
is that upgrades will still leave users with a broken config. Perhaps
we can change the kernel to still do the old behavior with no parameters.
Comment 13 Chris Evans 2001-04-03 18:24:52 EDT
Works for me as expected in QA0401.
Bill - you don't mind me closing this do you?
Comment 14 Bill Nottingham 2001-04-03 18:34:05 EDT
Sure, go ahead. it was fixed in the kernel.

Note You need to log in before you can comment on or make changes to this bug.