Bug 276831 - The scripts in /etc/cron.daily don't get run
The scripts in /etc/cron.daily don't get run
Status: CLOSED DUPLICATE of bug 269961
Product: Fedora
Classification: Fedora
Component: crontabs (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-04 14:02 EDT by Bruce Orchard
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 11:10:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Orchard 2007-09-04 14:02:58 EDT
Description of problem:
The scripts in /etc/cron.daily don't get run.  


Version-Release number of selected component (if applicable):
crontabs-1.10-15.fc7

How reproducible:
Every time


Steps to Reproduce:
1.  Let cron launch run-parts to run /etc/cron.daily
  
Actual results:
Nothing happens

Expected results:
The scripts in /etc/cron.daily get run

Additional info:

This started happening when crontabs-1.10-15.fc7 was installed as an update by
yum about August 29.  

I think the test at the beginning of /usr/bin/run-parts is backwards:

[root@3439-3 bin]# diff -c run-part.orig run-parts
*** run-part.orig       2007-08-27 01:59:50.000000000 -0500
--- run-parts   2007-09-04 12:37:40.000000000 -0500
***************
*** 2,8 ****
  # if cron.daily was run today
  AUX1=`cat /var/spool/anacron/cron.daily`
  AUX2=`date +%Y%m%d`
! [ "$AUX1" == $AUX2 ] || exit 0
  
  # run-parts - concept taken from Debian
  
--- 2,8 ----
  # if cron.daily was run today
  AUX1=`cat /var/spool/anacron/cron.daily`
  AUX2=`date +%Y%m%d`
! [ "$AUX1" == $AUX2 ] && exit 0
  
  # run-parts - concept taken from Debian
Comment 1 Marcela Mašláňová 2007-09-10 11:10:23 EDT

*** This bug has been marked as a duplicate of 269961 ***

Note You need to log in before you can comment on or make changes to this bug.