Bug 276881 - citrix client installs and works but can't log back into GDM and X session.
citrix client installs and works but can't log back into GDM and X session.
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
7
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-04 14:19 EDT by Jeff Greene
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-25 00:32:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Greene 2007-09-04 14:19:46 EDT
Description of problem:
My box is a Intel P4 D945GTP, Nvidia 7200...
In my case using either the Default Nvidia driver or using the restricted Nvidia
driver, the Citrix 10.6 Client Install worked fine and the client worked
perfectly; HOWEVER, the next time that I tried to log into GDM I got an error
saying something like "...my X session had lasted less than 10 seconds and would
I like to see the error log...".


Version-Release number of selected component (if applicable): 
2.6.20-16 kernel


How reproducible:
Happens every time on fresh system installs

Steps to Reproduce:
1. Ran a fresh Fedora 7 format/install/updates
2. Installed the Citrix Client and it worked
3. Logged out of Gnome and then couldn't log back in.
  
Actual results:
Completely ruins the system for end users. Same results with latest build of
Ubuntu Feisty and Gutsy.


Expected results:


Additional info:
Please see about adding the Citrix Client to the Fedora Repositories. No Citrix
Client is a Linux Deal-Breaker for me and most of my clients. -thanks
Comment 1 Ray Strode [halfline] 2007-09-04 17:30:18 EDT
do you log in and log out within 10 seconds?
Comment 2 Jeff Greene 2007-09-04 18:20:26 EDT
Hi Ray,
I was paraphrasing the error message about "..X session lasted less than 10
seconds...". Sorry. I wrote it down but left it at home. I can quote it later
tonight if needed. 
It seems to be an X message.
To answer your question, the system will not log into GDM even after 10 seconds
or after full reboot.
Comment 3 Jeff Greene 2007-09-05 23:49:16 EDT
I built a test system today with fresh Fedora 7 install with all updates and the
debugging packages installed. I can run some tests in the morning when I get to
the office. Is there anything specific that you would like me to test?
Comment 4 Ray Strode [halfline] 2007-09-06 10:22:36 EDT
If you could set Enable=true in the [debug] section of /etc/gdm/custom.conf,
restart, reproduce the problem, and attach /var/log/messages, that would be good.
Comment 5 Brian Powell 2008-04-25 00:32:34 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there have not been any
updates to the report since thirty (30) days or more since we
requested additional information, we're assuming the problem
is either no longer present in the current Fedora release, or
that there is no longer any interest in tracking the problem.

Setting status to "CLOSED INSUFFICIENT_DATA".  If you still
experience this problem after updating to our latest Fedora
release and can provide the information previously requested, 
please feel free to reopen the bug report.

Thank you in advance.

Note that maintenance for Fedora 7 will end 30 days after the GA of Fedora 9.

Note You need to log in before you can comment on or make changes to this bug.