Bug 27694 - uses wrong realtek driver for net install
uses wrong realtek driver for net install
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-14 21:51 EST by Sean Dilda
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-02 11:26:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sean Dilda 2001-02-14 21:51:17 EST
This is with rawhide from Feb 11, 2001

My machine has a Realtek 8139 ethernet card.  I boot the boot disk by
typing 'linux' at the lilo prompt, then on the network card selection
screen press F2 for driver disk, then put in the driver disk and it reads
it.  It doesn't scan the pci bus again, but instead just gives me the list
of ethernet card drivers.  I chose the Realtek one and it then tried to
load the rtl8129 driver, but failed to because it doesn't exist.

However, if I boot with 'linux dd' at the lilo prompt, give it the driver
disk at the proper point, etc, then it properlly loads the 8139too driver.

This seems to just be a simple 'typo' in the driver list, the rtl8129
should be 8139too
Comment 1 Bill Nottingham 2001-02-15 12:13:41 EST
This was fixed post beta. It should be in the next beta.
Comment 2 Sean Dilda 2001-04-01 13:56:36 EDT
This problem still exists in qa0328.
It works fine if I boot with 'linux dd' and put in the driver disk when asked. 
It uses rtl8139too for this.
But if I boot with 'linux', then press F2 for it to look at the driver disk, 
the list says the Realtek driver is rtl8129, and when I select it it tries to
load the rtl8129 driver and fails.
Comment 3 Michael Fulbright 2001-04-02 11:05:47 EDT
Matt please look at today if possible.
Comment 4 Matt Wilson 2001-04-02 11:09:00 EDT
Are you sure you didn't see *two* entries:

RealTek RTL8129 Fast Ethernet
RTL8139, SMC EZ Card Fast Ethernet

You should have picked the second one.
Comment 5 Sean Dilda 2001-04-02 18:58:24 EDT
Ok, I used the other option and it worked.  Closing bug.
However, the rtl8129 option shouldn't be there as the driver isn't there.  I
opened another bug on it. [Bug 34389]

Note You need to log in before you can comment on or make changes to this bug.