Bug 277471 - virt-manager causes segmentation-fault
virt-manager causes segmentation-fault
Status: CLOSED DUPLICATE of bug 307531
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-04 17:22 EDT by Patrick von der Hagen
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-26 22:55:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick von der Hagen 2007-09-04 17:22:48 EDT
Description of problem:
[root@localhost ~]# virt-manager 
Segmentation fault


Version-Release number of selected component (if applicable):
virt-manager.i386                        0.5.0-1.fc8            installed       
Matched from:
virt-manager
http://virt-manager.org/

kernel-xen.i686                          2.6.21-2933.fc8        installed       
Matched from:
kernel-xen

xen.i386                                 3.1.0-5.fc8            installed       
Matched from:
This package contains the Xen hypervisor and Xen tools, needed to
run virtual machines on x86 systems, together with the kernel-xen*
packages.  Information on how to use Xen can be found at the Xen
project pages.



How reproducible:


Steps to Reproduce:
1. login as root
2. run "virt-manager"

Actual results:
Segmentation fault

Expected results:
virt-manager should start up

Additional info:

Other virt-*-tools show the same problem. "virt-clone", "virt-image" 

Just the end of "strace virt-manager":

open("/usr/lib/python2.5/site-packages/libvirtmod.so", O_RDONLY) = 10
read(10, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0@,\0\0004\0\0\0"...,
512) = 512
fstat64(10, {st_mode=S_IFREG|0755, st_size=37340, ...}) = 0
mmap2(NULL, 40116, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 10, 0) = 0xc43000
mmap2(0xc4c000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE,
10, 0x8) = 0xc4c000
close(10)                               = 0
open("/etc/ld.so.cache", O_RDONLY)      = 10
fstat64(10, {st_mode=S_IFREG|0644, st_size=80806, ...}) = 0
mmap2(NULL, 80806, PROT_READ, MAP_PRIVATE, 10, 0) = 0xb7ba0000
close(10)                               = 0
open("/usr/lib/libvirt.so.0", O_RDONLY) = 10
read(10, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0PP\0\0004\0\0\0"...,
512) = 512
fstat64(10, {st_mode=S_IFREG|0755, st_size=354156, ...}) = 0
mmap2(NULL, 361520, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 10, 0) =
0xca5000
mmap2(0xcfb000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE,
10, 0x55) = 0xcfb000
mmap2(0xcfd000, 1072, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS,
-1, 0) = 0xcfd000
close(10)                               = 0
open("/usr/lib/libgnutls.so.13", O_RDONLY) = 10
read(10, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0p\27\1\0004\0\0\0"...,
512) = 512
fstat64(10, {st_mode=S_IFREG|0755, st_size=507700, ...}) = 0
mmap2(NULL, 510628, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 10, 0) =
0x6983000
mmap2(0x69fa000, 24576, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 10, 0x76) = 0x69fa000
close(10)                               = 0
open("/usr/lib/libxenstore.so.3.0", O_RDONLY) = 10
read(10,
"\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\320\21\0\0004\0\0\0"..., 512) = 512
fstat64(10, {st_mode=S_IFREG|0755, st_size=15464, ...}) = 0
mmap2(NULL, 30592, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 10, 0) = 0x7d5000
mmap2(0x7d9000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE,
10, 0x3) = 0x7d9000
mmap2(0x7da000, 10112, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x7da000
close(10)                               = 0
open("/lib/libgcrypt.so.11", O_RDONLY)  = 10
read(10, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0@>\0\0004\0\0\0"...,
512) = 512
fstat64(10, {st_mode=S_IFREG|0755, st_size=346204, ...}) = 0
mmap2(NULL, 345576, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 10, 0) =
0xeca000
mmap2(0xf1d000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE,
10, 0x53) = 0xf1d000
close(10)                               = 0
open("/lib/libgpg-error.so.0", O_RDONLY) = 10
read(10,
"\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\300\5\0\0004\0\0\0"..., 512) = 512
fstat64(10, {st_mode=S_IFREG|0755, st_size=11844, ...}) = 0
mmap2(NULL, 14648, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 10, 0) = 0x665000
mmap2(0x668000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE,
10, 0x2) = 0x668000
close(10)                               = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
Comment 1 Daniel Berrange 2007-09-04 17:33:18 EDT
Please install the -debuginfo RPMs for:

  virt-manager, libvirt, xen, python, pygtk2, gtk2, glib2 and glibc

And then set 'ulimit -c unlimited', run virt-manager, and then obtain a stack
trace from GDB:

  $ gdb /usr/bin/python core.XXXX
 (gdb) bt
   ....


Where core.XXXX is the corefile generated.
Comment 2 Daniel Berrange 2007-09-26 22:55:02 EDT
Turned out to be a GTK-VNC bug - fixed in rawhide.

 

*** This bug has been marked as a duplicate of 307531 ***

Note You need to log in before you can comment on or make changes to this bug.