Bug 277501 - cvs diff -r BASE -r HEAD complains about deleted files
cvs diff -r BASE -r HEAD complains about deleted files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cvs (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-04 17:40 EDT by Jonathan Lennox
Modified: 2015-02-01 17:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 05:22:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Lennox 2007-09-04 17:40:24 EDT
Description of problem:

When I do a cvs diff -r BASE -r HEAD (to see what has changed between the
version of a CVS repository I have checked out, and the most recent revision),
cvs prints the warning message

cvs diff: no revision in file [file name] or missing file [file name]

for every file that has been deleted in the history of the repository, even if
the file exists in neither BASE nor HEAD.

The same thing happens for any other pair of tags both of which do not apply to
a file.

Version-Release number of selected component (if applicable):
cvs-1.11.22-6.fc5

How reproducible:
Entirely

Steps to Reproduce:
1. Do cvs diff -pu -r BASE -r HEAD in a checkout of a repository which has
deleted files.
2. Observe what cvs prints on its standard error.
  
Actual results:

"No revision in file" messages for every file deleted in the history of the
repository.

Expected results:

Silence about files that exist in neither BASE nor HEAD.

Additional info:

This problem seems to be local to Fedora's version of cvs, and to have been
introduced by the fix to bug 18161 (cvs-1.11.21-diff.patch in the srpm).
Comment 1 Jiri Moskovcak 2007-09-05 08:55:12 EDT
Hi, I'm not sure this is good idea. User should know that there are differences
between the most recent version and the local version.

Jirka
Comment 2 Jonathan Lennox 2007-09-05 10:37:10 EDT
In the example I gave, there are no differences between the most recent version
and the local version.  In both cases, the file does not exist: it has been
removed earlier in the history of the repository.
Comment 3 Jiri Moskovcak 2007-09-06 08:50:00 EDT
I'm sorry, I didn't get it. You're right, that cvs should be quiet in this case,
it's quite confusing. I'm going to talk with upstream about the mentioned patch.

Jirka
Comment 4 Jiri Moskovcak 2007-09-18 05:22:07 EDT
Fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.