Bug 277521 - error: size of array '__open_missing_mode' is negative
error: size of array '__open_missing_mode' is negative
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Norm Murray
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-04 19:10 EDT by Robert Scheck
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-27 22:18:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
a patch to fix the issue - missing mode argument to open (551 bytes, text/x-patch)
2007-09-18 05:14 EDT, Norm Murray
no flags Details

  None (edit)
Description Robert Scheck 2007-09-04 19:10:54 EDT
Description of problem:
ImageMagick isn't rebuilding on Rawhide:

/bin/sh ./libtool --silent --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -
I./magick -I./wand  -I./ltdl -I./ltdl  -I/usr/include/freetype2 -I/usr/include/
libxml2  -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-
protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -
fasynchronous-unwind-tables -Wall -W -pthread -MT magick/magick_libMagick_la-
delegate.lo -MD -MP -MF magick/.deps/magick_libMagick_la-delegate.Tpo -c -o 
magick/magick_libMagick_la-delegate.lo `test -f 'magick/delegate.c' || echo './
'`magick/delegate.c
magick/delegate.c: In function 'CopyDelegateFile':
magick/delegate.c:767: error: size of array '__open_missing_mode' is negative
make: *** [magick/magick_libMagick_la-delegate.lo] Error 1

Version-Release number of selected component (if applicable):
ImageMagick-6.3.2.9-3

How reproducible:
Everytime.

Additional info:
Please notice, that this problem could be solved by a newer version of 
ImageMagick.
Comment 1 Norm Murray 2007-09-18 04:23:29 EDT
Nope, not directly solved by a new version. Looking into it
Comment 2 Norm Murray 2007-09-18 05:14:28 EDT
Created attachment 198251 [details]
a patch to fix the issue - missing mode argument to open

Note You need to log in before you can comment on or make changes to this bug.