Bug 277781 - conga passes fence_scsi nodename, where as it accepts only node
conga passes fence_scsi nodename, where as it accepts only node
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Ryan McCabe
Cluster QE
: Reopened
Depends On:
Blocks: 286951
  Show dependency treegraph
 
Reported: 2007-09-05 02:07 EDT by Norm Murray
Modified: 2010-10-22 14:24 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2008-0347
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:57:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for fence_scsi to accept both node and nodename as valid parameters. (278 bytes, text/x-patch)
2007-09-05 02:19 EDT, Wade Mealing
no flags Details

  None (edit)
Description Wade Mealing 2007-09-05 02:07:05 EDT
Description of problem:

Luci creates a invalid xml file, which creates incorrect parameters for
fence_scsi. It presents "nodename" whereas the code itself only accepts node.

The man page for fence_scsi also sugguests that the fence_scsi perl script
should take nodename=value on the stdin, although this does not seem to be the case.

I've lodged this against fence, as I believe that the simplest fix is to fix
with the minimum behavioral change.

There is also no fence component in the RHEL bugzilla list.
Comment 1 Wade Mealing 2007-09-05 02:19:13 EDT
Created attachment 186901 [details]
Patch for fence_scsi to accept both node and nodename as valid parameters.
Comment 2 RHEL Product and Program Management 2007-09-05 02:22:42 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.
Comment 3 Wade Mealing 2007-09-05 02:56:44 EDT
Bumped for 5.2
Comment 4 Ryan McCabe 2007-09-05 12:14:03 EDT
fence is subsumed by cman for rhel5
Comment 6 Ryan McCabe 2007-09-20 23:14:24 EDT
Changed fence_scsi to accept "nodename" in addition to "node." I've also changed
conga to set "node" to be backwards compatible.
Comment 11 errata-xmlrpc 2008-05-21 11:57:43 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0347.html

Note You need to log in before you can comment on or make changes to this bug.