Bug 277911 - several modes don't respect --width and --height
several modes don't respect --width and --height
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: zenity (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-05 03:37 EDT by Jane Dogalt
Modified: 2008-04-22 18:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 18:38:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jane Dogalt 2007-09-05 03:37:08 EDT
Description of problem:

several zenity modes don't respect --width and --height.  The problem is pretty
simple, in /usr/share/zenity/zenity.glade, the widgets/windows for the modes
have resizable=False, when it should be True, such that the C-code changing the
size actually has an effect.  For example-

<widget class="GtkDialog" id="zenity_question_dialog">
  <property name="border_width">5</property>
  <property name="title" translatable="yes">Question</property>
  <property name="type">GTK_WINDOW_TOPLEVEL</property>
  <property name="window_position">GTK_WIN_POS_CENTER</property>
  <property name="modal">False</property>
  <property name="resizable">False</property>
                             ^^^^^

If you change that to True, then "zenity --question --width=640 --height=480"
will work as it should.  There a few others with the same bug, just search for
resizable in the .glade file.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Clasen 2008-04-22 18:38:07 EDT
I've reported this problem upstream: 
http://bugzilla.gnome.org/show_bug.cgi?id=529452

Note You need to log in before you can comment on or make changes to this bug.