Bug 278151 - Duplicated library librpmdb-4.4.so
Duplicated library librpmdb-4.4.so
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-05 06:29 EDT by Michael Schwendt
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-05 07:50:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2007-09-05 06:29:53 EDT
rpm-devel provides librpmdb-4.4.so
rpm-libs provides librpmdb-4.4.so
  required by: apt - 0.5.15lorg3.93-2.fc8.i386
  required by: deltarpm - 3.4-6.fc8.i386
  required by: perl-RPM2 - 0.67-2.fc7.i386
  required by: rpm - 4.4.2.2-0.1.rc1.i386
  required by: rpm-build - 4.4.2.2-0.1.rc1.i386
  required by: rpm-libs - 4.4.2.2-0.1.rc1.i386
  required by: rpm-python - 4.4.2.2-0.1.rc1.i386
  required by: apt - 0.5.15lorg3.93-2.fc8.i386
  required by: deltarpm - 3.4-6.fc8.i386
  required by: perl-RPM2 - 0.67-2.fc7.i386
  required by: rpm - 4.4.2.2-0.1.rc1.i386
  required by: rpm-build - 4.4.2.2-0.1.rc1.i386
  required by: rpm-devel - 4.4.2.2-0.1.rc1.i386
  required by: rpm-python - 4.4.2.2-0.1.rc1.i386

It is a big versioned DSO file, not a symlink and hence need
not be included in rpm-devel, because it's included in rpm-libs
already.
Comment 1 Panu Matilainen 2007-09-05 07:50:03 EDT
Ew, oops :) Thanks for noticing, must be fallout from the recent grande spec
cleanup.

Fixed in next rawhide push (rpm-4.4.2.2-0.4.rc1)

Note You need to log in before you can comment on or make changes to this bug.