Bug 27816 - Bugs In kernel-source postinstall script
Bugs In kernel-source postinstall script
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-15 12:10 EST by derrien
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-15 12:10:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description derrien 2001-02-15 12:10:43 EST
rpm -q --scripts kernel-source 

postinstall script (through /bin/sh):
cd /usr/src
rm -f linux
ln -snf linux-2.2.17 linux
if [ 1 -eq 0 ] ; then                                <--- Is there some
situations where 1=0 ???
        cd /usr/include
        rm -f linux asm                             <--- /usr/include/linux
and /usr/linux/asm can be
                                                                 
directories, then this command doesn't work.
        ln -snf ../src/linux/include/linux linux
        ln -snf ../src/linux/include/asm asm
fi
Comment 1 Michael K. Johnson 2001-02-15 12:16:03 EST
It's a %define -- it doesn't look like that in the source to
the spec file.   It's a packaging thing and isn't a bug, though
it certainly looks strange.

If they are directories, not links, then we didn't put them
there and we shouldn't be removing them.  Not a bug.
Comment 2 derrien 2001-02-16 04:53:19 EST
Thanks for the fast answer but 7.0  install kernel-headers-2.4.0-0.26.i386.rpm
(Cf bug 20257) with linux and asm directories, so after update with 
kernel-source-2.2.17-14 we still have /usr/include/linux and /usr/include/asm
for the 2.4 version...
Comment 3 Michael K. Johnson 2001-02-16 09:47:05 EST
Correct, that's exactly as it should be.
Comment 4 derrien 2001-02-16 10:03:22 EST
Sorry but I don't understand. why..
Could you explain me the use of 2.4 headers with a 2.2 kernel ?

In bug 20257 it's said 
"Correct. If you want the module headers, install the 2.2.16 kernel-source
package."

So I have installed kernel-source package but I still have the
/usr/include/linux of version 2.4 then when I try to compile my program thinks
it's  a 2.4 machine and it doen't work.


Comment 5 Michael K. Johnson 2001-02-16 10:20:47 EST
Building programs that can take advantage of 2.4 kernel features but
can run on both kernels...

Build with
  -I /lib/modules/$(uname -r)/build/include/
to get the right headers when you are building modules.
You can have multiple kernels installed, so depending on
/usr/include/{linux,asm} links is not sufficient.

Note You need to log in before you can comment on or make changes to this bug.