Bug 278191 - Conflicting Provides
Summary: Conflicting Provides
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibmm24   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Denis Leroy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-05 11:02 UTC by Michael Schwendt
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-06 09:49:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Schwendt 2007-09-05 11:02:38 UTC
glibmm24-devel provides perl(Util) EQ 0 1.00
fedora-ds-base provides perl(Util)
  required by: glibmm24-devel - 2.13.9-2.fc8.i386
  required by: fedora-ds-base - 1.1.0-1.2.fc8.i386

Comment 1 Denis Leroy 2007-09-05 11:53:42 UTC
Hmm, ok. So the gtkmm stack uses a Perl-based code generation system (the C++
source code is generated automatically from source templates).

It turns out that the automake setup for some reasons installs the Perl
autogeneration scripts under /usr/lib/glibmm-2.4/proc, and the perl files are
picked up automatically by RPM, and therefore pollute the RPM perl namespace.

I don't know why the perl files are installed since they're not really meant to
be used by developers. I'll check upstream.

I'll just rm -r /usr/lib/glibmm-2.4/proc after installation and push an update.


Comment 2 Denis Leroy 2007-09-06 09:49:15 UTC
"They are useful for creating other *mm projects, yes. But it's not awful
if they are not installed by the distro."

If someone requests it, I'll package them separately with an extra namespace.
Removed for now.



Note You need to log in before you can comment on or make changes to this bug.