Bug 27821 - Redboot mangling dependent on flash driver?!
Redboot mangling dependent on flash driver?!
Status: CLOSED CURRENTRELEASE
Product: eCos
Classification: Retired
Component: RedBoot (Show other bugs)
CVS
All Linux
medium Severity medium
: ---
: ---
Assigned To: ecc-bugs-int
ecc-bugs-int
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-15 13:11 EST by Jonathan Larmour
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-07 03:33:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Larmour 2001-02-15 13:11:17 EST
Look at the thread "Mangling output" on Thursday 15th Feb 2001. RedBoot
wasn't mangling console output, then Hugo found this out:

"
I persisted with my other work - adding a flash driver - 'cos it needs
doing anyway, and doing that brings my target more into line with the other
targets that work.  And LO! suddenly mangling works too.

Yes, just confirmed that.  Build RedBoot but remove the flash packages and
it fails, build it "vanilla" and it works, the very same app binary and
everything - just a new ROM build with FLASH packages.

So, there's a RedBoot bug in there somewhere, I suspect, but I don't care -
it works now.

"
Comment 1 Jesper Skov 2001-02-22 03:41:02 EST
Jesper> OK, I'll have a look at the CDL state.

Uh, baffled. No changes in the pkgconf headers (or CDL) which should
be even remotely related.

Off the top of my head, I'd guess at something related to
caching. Flash drivers do some flushing at init time which you don't
get otherwise.  And looking at the sa11x0 init code, there's no flush
before caches are enabled... Guess it could be done earlier, but
hal_if_init call is just before caches get enabled...

Jesper
Comment 2 Jesper Skov 2001-03-07 03:32:55 EST
Was due to missing HAL_DIAG_INIT call - now done from RedBoot main function.
(including flash drivers would pull in diag_printf clients and thus the init
call).

Note You need to log in before you can comment on or make changes to this bug.