Bug 278241 - anaconda cannot find iso image on hard drive
anaconda cannot find iso image on hard drive
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-05 07:58 EDT by Luigi Tarenga
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: f8test2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-30 07:21:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
contains the anaconda log, lsmod, uname and df output (4.62 KB, application/octet-stream)
2007-09-05 07:58 EDT, Luigi Tarenga
no flags Details

  None (edit)
Description Luigi Tarenga 2007-09-05 07:58:44 EDT
Description of problem:
i was trying to install fedora 8 test1 from local drive.
first i tried to installed from a directory containing all rpms
but i find that anaconda only accept iso image.

so i build the image with the following command:
cd /home/vortex/fedora-7.90-x86_64/
genisoimage -no-emul-boot -boot-load-size 4 -c isolinux/boot.cat
-boot-info-table -b isolinux/isolinux.bin -R -J -V 'linux' -T -o ../image.iso .

(/home/vortex/fedora-7.90-x86_64 is a copy of
releases/test/7.90/Fedora/x86_64/os/  i got from a fedora mirror server)

i booted with grub from the fc8 kernel:
        root (hd0,0)
        kernel /home/vortex/fedora-7.90-x86_64/isolinux/vmlinuz
        initrd /home/vortex/fedora-7.90-x86_64/isolinux/initrd.img

during installation i choosed to use a local image on hard disk, 
i suggested the /home/vortex directory and the process accept it and goes on, i
partition disk drives, i choose to configure eth0 with dhcp etc., then after the
root password i get an error that anaconda can't find the iso image, i'm
suggested to copy the iso to the hard drive, then i can "exit" or "retry". 
i went to tty2 and the df show:
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev                   1017860         0   1017860   0% /dev
/tmp/loop1               97920     97920         0 100% /mnt/runtime
/dev/sdb1             31006796  20258452   9147872  69% /tmp/isodir

(i think this is incorrect, the iso is inside /tmp/isodir/home/vortex/)

so i tried to correct it like:
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev                   1017860         0   1017860   0% /dev
/tmp/loop1               97920     97920         0 100% /mnt/runtime
/dev/sdb1             31006796  20258452   9147872  69% /prova
/dev/loop0             3381778   3381778         0 100% /tmp/isodir

(i mounted image.iso on /tmp/isodir)
i returned to tty1 and choosed "retry" in the installation process.
at this point it hang with and exception (see attached files).

 
my hd configuration is:
sda : containing vista - not used by linux at all
sdb : sdb1 / for fc7 and containing the fc8 iso file (i named it image.iso)
      sdb2 free space (32G) for fc8
      sdb3 free space

Version-Release number of selected component (if applicable):


How reproducible:
try to install from hard disk with the fc8 iso built from mirror

Steps to Reproduce:
1. mirror fc8 x86_64 os directory
2. build the iso
3. boot from fc8 kernel and choose to install from hard drive
  
Actual results:
anaconda fail to find/mount the image

Expected results:


Additional info:
Comment 1 Luigi Tarenga 2007-09-05 07:58:44 EDT
Created attachment 187271 [details]
contains the anaconda log, lsmod, uname and df output
Comment 2 Chris Lumens 2007-09-05 09:38:40 EDT
I think this should be fixed in the next build of anaconda.  Marking as MODIFIED
until we get a chance to test.
Comment 3 Luigi Tarenga 2007-09-05 13:17:25 EDT
thank you Chris,
just for your info, i tried the same procedure with the following variation:

- putting image.iso in a empy file system
- using the rescuecd.iso (same version and platform) instead of image.iso
(i feared i had built a broken image so i tried with an official one)

the results are the same.

i wait for the next build.
Comment 4 Luigi Tarenga 2007-09-25 12:37:45 EDT
Hi Chris,
forgive me for the delay in the reply :P
it seems that the bug as been fixed with the fedora 8 test2 release.
i'm able to install with the iso mounted in loopback.
should i close the bug?

many thanks

Note You need to log in before you can comment on or make changes to this bug.