Bug 27829 - How to stop Kickstart prompting for firewall config
How to stop Kickstart prompting for firewall config
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ksconfig (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-15 14:20 EST by David Ross
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-15 15:50:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Ross 2001-02-15 14:20:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.11 i686)


I'd like to have Kickstart go completely unattended.  i.e., put the CD in,
reboot and 10 minutes later, I've got a new machine.  
In Fisher, anaconda prompts for the Firewall configuration that I want.  I
would like to be able to enter something in the kickstart config file to
preanswer that question.  Anyone know what that is, or if that is supported
(yet)?

Actually, while I'm at it, on a machine with more than 1 network interface,
it also prompts me for which interface I want to use for the install.  I
would like to specify that in the kickstart file as well.  The firewall
config is more important however.

Reproducible: Always
Steps to Reproduce:
1.  Boot a machine from a kickstart floppy/cd with a server set up to
provide the DHCP info and NFS RedHat install.
	

Actual Results:  The anaconda prompt for which firewall configuration I
want appears on the screen.  After answering the question, things hum along
merrily.

Expected Results:  I should be able to provide the answer in the kickstart
file and the question should never appear.
Comment 1 Bill Nottingham 2001-02-15 15:50:34 EST
You can. :)

firewall [--high | --medium | --disabled] [--trust device (trusted
device)] [--trust (trusted device)] [etc...] [--dhcp] [--ssh]
[--telnet] [--smtp] [--http] [--ftp] [--port] [--port (port number)]
[etc...]
Comment 2 David Ross 2001-02-16 17:31:37 EST
Woohoo!!  Thanks!
So I don't ask such silly questions in the future - is there newer documentation for kickstart that describes these options?

I would also like to be able to tell kickstart which interface to use on a multi-NIC machine.  I also want to make sure I know I've got the RAID options 
correct (I keep getting an error about md1 and md3 overlapping physical somethings with md2 (swap)).  

Any pointers appreciated!  Thanks!
Comment 3 Brent Fox 2001-02-16 17:44:05 EST
Yes, there are newer docs, but they aren't publicly available yet because they
aren't quite finished.  It would be nice to make them available with the beta,
but it's hard to document software that is still in flux.
Comment 4 David Ross 2001-02-16 20:56:07 EST
So nothing available, even unfinished, that I could steal?
Comment 5 David Ross 2001-02-17 22:06:51 EST
What about support for the Logical Volume Manager and/or ReiserFS/ext3?  
Okay, I'm asking for a lot now, but I'd LOVE to have this.  Thanks, guys!

Note You need to log in before you can comment on or make changes to this bug.