Bug 278601 - Nonstandard behavior of dhcpd init script
Nonstandard behavior of dhcpd init script
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
: EasyFix
: 246907 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-05 11:19 EDT by Lubomir Kundrak
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-26 15:22:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2007-09-05 11:19:55 EDT
Description of problem:

These lines bother me:

    restart)
        configtest || exit $?
        stop
        start
        ;;

Is it really wise to check configuration and die silently if the check fails?
Most services don't do this. Maybe it would be enough if configtest was a bit
more verbose, like: 'Checking configuration [FAILED]', or, better, wasn't
present at all. There's still a "testconfig" target in case someone wishes to
test the config.

Version-Release number of selected component (if applicable):

dhcp-3.0.6-3.fc8

Additional info:

I don't know anything about whether this is or isn't LSB compilant.
Comment 1 David Cantrell 2007-09-05 11:26:56 EDT
Good catch.  I'll work on that later.  Thanks for the report.  I have been
slowly working on making it LSB compliant, but that's sort of a rainy day
project honestly.

/me waves the not-the-original-author flag  :)
Comment 2 David Cantrell 2007-09-26 15:22:43 EDT
Fixed in rawhide (dhcp-3.0.6-6.fc8).  I've changed the dhcpd and dhcrelay
scripts to conform with the Fedora initscript guidelines in addition to removing
the unnecessary configtest call you reported.

Thanks.
Comment 3 David Cantrell 2007-09-26 15:23:52 EDT
*** Bug 246907 has been marked as a duplicate of this bug. ***
Comment 5 Michael Schwendt 2007-10-08 11:55:12 EDT
While running into bug 320761, I've stumbled into this, too.

"restart" should call "start" even if "stop" failed. That is,
it should attempt a "start" *always*, even if dhcpd is stopped
in unknown ways.

The way you've changed it, "restart" is like "condrestart" except
for the lockfile-check.

Note You need to log in before you can comment on or make changes to this bug.