Bug 278671 - steghide fails to open libmcrypt module on mcrypt_module_open
steghide fails to open libmcrypt module on mcrypt_module_open
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libmcrypt (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 275641
  Show dependency treegraph
 
Reported: 2007-09-05 11:58 EDT by Jochen Schmitt
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-09 11:29:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposal Patch (280 bytes, patch)
2007-10-09 10:21 EDT, Jochen Schmitt
no flags Details | Diff
corrected Patch (583 bytes, patch)
2007-10-09 10:36 EDT, Jochen Schmitt
no flags Details | Diff

  None (edit)
Description Jochen Schmitt 2007-09-05 11:58:38 EDT
On BZ 275641 an user compaints, thst steghide fails with the following
error message:

steghide: could not open libmcrypt module "rijndael-128", "cbc"

My examination shows, that this error message will produced from the
mcrypt_module_open call in the MCryptPP.cc file of steghide.

The call looks like:


	if ((MCryptD = mcrypt_module_open (algo, MCRYPTPP_LIBDIR, mode,
MCRYPTPP_LIBDIR)) == MCRYPT_FAILED) {
		throw SteghideError (_("could not open libmcrypt module \"%s\",\"%s\"."),
algo, mode) ;
	}

It will be nice, if you can get a look on it.
Comment 1 Jochen Schmitt 2007-10-09 10:21:00 EDT
Created attachment 221291 [details]
Proposal Patch
Comment 2 Hans de Goede 2007-10-09 10:28:31 EDT
Wrong component, changing. Also next time please use diff -u when generating
patches.
Comment 3 Jochen Schmitt 2007-10-09 10:36:20 EDT
Created attachment 221311 [details]
corrected Patch
Comment 4 Jochen Schmitt 2007-10-09 10:38:49 EDT
At last, the reported issue was caused my libmcrypt, which I have selected as
the correct component for this bug report.
Comment 5 Tom "spot" Callaway 2007-10-09 10:44:35 EDT
Just not enabling the static lib resolves this bug? Thats a little odd, are you
sure?
Comment 6 Tom "spot" Callaway 2007-10-09 11:20:41 EDT
nm, i see. I'll fix that rightaway.

Note You need to log in before you can comment on or make changes to this bug.