Bug 27869 - fails dependencies when the module exists
Summary: fails dependencies when the module exists
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: ethereal   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Powers
QA Contact: David Lawrence
URL: gsimpson@mountaincable.net
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-15 23:53 UTC by Glenn Simpson
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-17 23:31:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Glenn Simpson 2001-02-15 23:53:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.11 i586)


When attempting to load either ethereal 8.14-1 or 8.15-1, RPM fails to find
module libsnmp.so.0, dispite the module link is in the correct directory.
The same RPMs load without issue on 7.0 where the same link and module is
in the same directory as on Fisher

I have rebuilt the rpm db and that had no effect.

Reproducible: Always
Steps to Reproduce:
1.Obtain an ethereal RPM (ex:: ethereal-0.8.15-1)
2.Issue the command  rpm -ivh ethereal........
3.You will find that module libsnmp.so.0 is not found.  But it does exist
in directory /usr/lib
	

Actual Results:  The rpm fails to install.
Rebuilding the RPM DB has not effect.  It still fails to install.

The same conditions on 7.0 show no issues.

Expected Results:  With link /usr/lib/libsnmp.so.0 in place, the install
should have no complaint when executing  rpm -ivh
ethereal-0.8.15-1.i386.rpm there should be no complaint of can not find the
module

Comment 1 Jeff Johnson 2001-02-16 23:03:04 UTC
This is a packaging problem, not an rpm problem, and is not present AFAICT
in ethereal-0.8.15-2 which has no dependency on libsnmp.so.0 at all.

What that means is that snmp support has dropped out of ethereal, probably
because of failure to autoconfigure with snmp support, so I'll assign the
problem to ethereal, which,
if it is to have snmp support, needs to detect and link against  the renamed
(but compatible)
libraries in the ucd-snmp-4.2 package.

Comment 2 Glen Foster 2001-02-17 23:31:33 UTC
We (Red Hat) should really try to resolve this before next release.

Comment 3 Tim Powers 2001-02-19 15:33:13 UTC
ethereal-0.8.15-2 is the current version and doesn't have this problem. I am
resolving this as rawhide. The problem appears to be a buildroot that wasn't
updated to the newer ucd-snmp packages. I am marking this as "Resolved rawhide".

Tim

Comment 4 Glenn Simpson 2001-02-21 16:50:14 UTC
Where can I find ethereal-8.15-2  The latest I can find at
www.ethereal.com/distribution is 8.15-1


Comment 5 Tim Powers 2001-02-21 17:02:21 UTC
It should be in ftp://ftp.redhat.com/pub/rawhide/powertools/i386/RedHat/RPMS .

Tim

Comment 6 Tim Powers 2001-02-21 17:14:27 UTC
My mistake. It isn't there either. I just uploaded the packagees to
http://people.redhat.com/timp/SRPMS and http//people.redhat.com/timp/RPMS now,
so they are somewhere you can get to :)

Tim


Note You need to log in before you can comment on or make changes to this bug.