Bug 27912 - TUI/Japanese-pkg. group selection screen has funny chars.
TUI/Japanese-pkg. group selection screen has funny chars.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2001-02-15 20:13 EST by Ben Levenson
Modified: 2007-03-26 23:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-17 15:05:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to improve the handling multibytes. but not perfect., I think. (21.13 KB, patch)
2002-06-03 09:42 EDT, Akira TAGOH
no flags Details | Diff
fix the wordwrap issue. (21.14 KB, patch)
2002-06-07 08:53 EDT, Akira TAGOH
no flags Details | Diff

  None (edit)
Description Ben Levenson 2001-02-15 20:13:59 EST
build: qa0215.1
TUI http/ftp/hard drive custom install
using the arrow keys to scroll through the package groups
causes funny characters to appear in the package group titles.
they disappear once the item is 'hi-lighted'.
this seems like a cosmetic bug--the overall function of the screen 
doesn't appear to be compromised
Comment 1 Michael Fulbright 2001-02-16 21:18:47 EST
Is this one of those slang-j issues?
Comment 2 Glen Foster 2001-02-17 18:29:12 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 3 Eido Inoue 2001-02-18 20:55:21 EST
Yes it's a minislang-j issue. I don't know about the MUST-FIX status-- we're
currently using the "partially Japanese patched" minislang-j (vs the real
slang-j which should work) due to space issues.

If space is not the issue, should we assign one of the ja team to fix minislang
and Japanese?

Tago and I have a patch for the full slang for I18N/multibyte if we can use it.
Comment 4 Michael Fulbright 2002-05-01 12:27:56 EDT
Is this a problem in Hampton?
Comment 5 Akira TAGOH 2002-05-07 04:44:57 EDT
The package groups is ok. but when confirm on automatic partitioning, some
characters on background window is broken. IIRC our patch should be fixed this
problem too.
Comment 6 Michael Fulbright 2002-05-09 14:50:16 EDT
Is there a particular person I should assign this to? Space IS not an issue in
stage 2, right jeremy?
Comment 7 Jeremy Katz 2002-05-09 16:46:02 EDT
minislang is only used in the loader, so it isn't an issue here.  We're already
using the default system libslang for stage2, so if it gets fixed there, it
should fix it (well, unless it exposes other newt bugs)
Comment 8 Akira TAGOH 2002-05-10 03:58:07 EDT
Ok, I see. I think probably this problem will be related libslang, because
libslangj should be fixed this problem.
BTW It seems that slang on Debian has UTF-8 support. I'll try it for integration
whether this problem is fixed or not.
Comment 9 Akira TAGOH 2002-06-03 09:42:56 EDT
Created attachment 59351 [details]
Patch to improve the handling multibytes. but not perfect., I think.
Comment 10 Akira TAGOH 2002-06-07 08:53:02 EDT
Created attachment 60011 [details]
fix the wordwrap issue.
Comment 11 Jeremy Katz 2002-07-17 15:05:34 EDT
Bill -- you're the one who's looked the most at this stuff recently I think.
Comment 12 Bill Nottingham 2002-08-21 12:29:57 EDT
This isn't really relevant to the new newt's mb wrap code; hopefully, that
solves this issue.

Note You need to log in before you can comment on or make changes to this bug.