Bug 279231 - ZynAddSubFX's main window slow to respond on KDE. No problems on Gnome.
ZynAddSubFX's main window slow to respond on KDE. No problems on Gnome.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: zynaddsubfx (Show other bugs)
7
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Anthony Green
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-05 15:43 EDT by Nigel Henry
Modified: 2008-06-16 22:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 22:19:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Henry 2007-09-05 15:43:46 EDT
Description of problem: 
Opening ZynAddSubFx's main window in KDE results in 100% CPU useage, and it's 
very difficult and slow to close the app. Other apps still can be opened on 
the desktop, so it's not a case of the desktop being frozen up, but just 
appears to apply to Zyn's main window. If I minimise Zyn the CPU cycles return 
to normal. If I click on a box in Zyn that opens child windows, then minimise 
Zyn, the child windows open ok, and are useable with no problems. 
 
If I logout of KDE, and login to Gnome, and open ZynAddSubFX, the app works as 
it should, with no problems. 
 
It appears to be a problem only with Zyn, and with KDE. 
 
Other distros on the same machine (FC1,2,3,4,and 5. Debian Sarge, Etch, and 
Lenny) have no problems with ZynAddSubFX and KDE. 
 
 
Version-Release number of selected component (if applicable): 
2.2.2-14.fc7 
 
 
How reproducible: 
Always 
 
 
Steps to Reproduce: 
1. 
2. 
3. 
   
Actual results: 
 
 
Expected results: 
 
 
Additional info:
Comment 1 Anthony Green 2007-10-16 22:08:52 EDT
I wonder if this has more to do with fltk than zynaddsubfx.  In any case, I'm no
KDE expert and I could use some help looking into this.

Comment 2 Nigel Henry 2007-11-27 15:14:17 EST
I now have F8 installed on the same machine, and am getting the same results 
with Zyn on KDE. I again posted the problem to planetccrma, and someone 
replied saying that Zyn worked ok with F8, and KDE on his machine, and posted 
me his zyntrace.txt. I compared it with mine in KDE's Kompare, but am not 
clued up enough to understand the strace output. there are a lot of 
differences between his and mine, but may be hardware related. 
 
You mention a possible problem with fltk, but would this explain why Zyn works 
ok with Gnome, but not with KDE? 
 
I got no replies when I posted the problem with Zyn on F7 to the KDE list. 
I'll post the problem again referencing F8, but as ZynAddSubFX is not a KDE 
app, perhaps they are not too interested. 
 
Anyway. Zyn works on FC1 through FC5 on this machine with KDE, but it would be 
nice to find out why it is totally screwed up on F7, and F8 with KDE. 
 
Nigel. 
Comment 3 Nigel Henry 2007-12-11 15:31:49 EST
Anthony. This does appear to be an fltk problem, I've only tried this on 
Fedora 8 up to now, but the procedure is to remove fltk, along with Zyn from 
Fedora 8, then install the fltk version that I've borrowed from FC5 
(version-fltk_1.1.7-1.fc5_i386.rpm), and followed by a reinstall of 
ZynAddSubFX. Now Zyn works ok, as per pre FC7 installs of Fedora. 
 
Should I post this as a bug against fltk? 
 
Nigel. 
Comment 4 Anthony Green 2007-12-11 15:38:29 EST
(In reply to comment #3)
> Should I post this as a bug against fltk? 

Yes, I think so. Mark that bug as blocking this one.  Thanks.

Comment 5 Bug Zapper 2008-05-14 10:14:47 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2008-06-16 22:19:51 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.