Bug 27930 - Cirrus X Server
Cirrus X Server
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-15 23:23 EST by Ray Parish
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-19 08:28:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ray Parish 2001-02-15 23:23:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


Cirrus chipset GD5480 with the Xserver causes translucent windows in KDE 
and GNOME.

Reproducible: Always
Steps to Reproduce:
1.Install Fisher
2.During Install and setup of X you should notice the problem.
3.
	

Actual Results:  Translucent windows

Expected Results:  No translucent windows

Even installing rawhide1 to RH7 produced the same functionality in X when 
upgraded.
Comment 1 Mike A. Harris 2001-02-16 00:24:03 EST
Try using the latest rawhide version of XFree86-4.0.2-9.  The 3.3.6 package
should only be used if XFree86-4.0.2 fails.  I just recently added a patch for
this card.
Comment 2 Ray Parish 2001-02-19 07:23:30 EST
Ok I update to the rawhide version of XFree86-4.0.2-9, how can I tell if I am 
running the XFree86 version 4 rather than the version 3? Is there a way to 
force the version 4 to run and not to fall back on version 3?
Thanks

Ray
Comment 3 Ray Parish 2001-02-19 07:39:06 EST
Went to rawhide.redhat.com, I pulled down

XFree86*
Xconfigurator*
Glide*
Mesa*
freetype*

I then did a 
rpm -ivh Glide*
rpm -Fvh *.rpm

I then restarted Xserver and now have the translucent windows. I am running
XFree86-4.0.2-6 (which is the latest on rawhide)
Thanks
Comment 4 Mike A. Harris 2001-02-19 07:57:00 EST
In answer to your first question, you use XFree 4, by specifying:
	Xconfigurator --preferxf4

This forces XFree86 4.0.2 to be used.  In answer to your second entry,
You said you're using XFree86-4.0.2-6, and are still having the problem.
This does not come as a surprise to me because I said to try:
XFree86-4.0.2-9 out when it is available, which it isn't right now.
So...  I've put it in my FTP space for you.  You can find it at:
ftp://people.redhat.com/mharris/XFree86/4.0.2-9/

If you try it out, please update the bug report wether it works or not.
If it works for you, I can then close the bug report.  Thanks, and good
luck!




Comment 5 Ray Parish 2001-02-19 08:28:55 EST
Ftp'd to the mentioned site and grabbed the XFree86-4.0.2-9 files and did
rpm -Fvh *.rpm

restarted X server and all is working.

Thanks for the quick fix!
Ray

Note You need to log in before you can comment on or make changes to this bug.