Bug 279301 - avahi-daemon initscript is failing on boot of the desktop spin live image
Summary: avahi-daemon initscript is failing on boot of the desktop spin live image
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: avahi
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F8Test3
TreeView+ depends on / blocked
 
Reported: 2007-09-05 20:06 UTC by Zack Cerza
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2007-09-25 00:22:32 UTC


Attachments (Terms of Use)

Description Zack Cerza 2007-09-05 20:06:29 UTC
Description of problem:
Using rawhide-20070904.0.iso on a usb stick, the avahi-daemon service is failing
to start on boot. It succeeds if I start it manually after booting. Let me know
if you need more information.

Version-Release number of selected component (if applicable):
avahi-0.6.21-3.fc8

Comment 1 Ronald Warsow 2007-09-05 20:34:59 UTC
on the rawhide live cd from 05.09.2007

avahi-daemon: segfault at 00000000 eip 0804cc50 esp bfc78460 error 4
on boot up, but is restartable without segfault

Comment 2 Lennart Poettering 2007-09-06 15:15:38 UTC
Hmm, this is really difficult to debug without a proper backtrace. Could you
please try to generate one via a gdb script?

Also, what does syslog say before the crash happens?



Comment 3 Zack Cerza 2007-09-06 16:04:00 UTC
It's difficult, since I'm booting from a live image, and the second time it
starts it doesn't segfault. I don't think I'll be able to get you a backtrace
until I can install it, which is blocked by bug #278711.

Comment 4 Lennart Poettering 2007-09-21 14:32:41 UTC
Zack, any update on this?

Comment 5 Zack Cerza 2007-09-21 16:39:09 UTC
I'll check today.

Comment 6 Matthias Clasen 2007-09-22 02:28:49 UTC
Ok, I had a look, and it seems that the absence of /etc/resolv.conf makes
avahi-daemon segfault.

I've booted the live cd in single user mode, and started dbus.
then

/usr/sbin/avahi-daemon 

segfaults, but 

touch /etc/resolv.conf
/usr/sbin/avahi-daemon

succeeds

Comment 7 Lennart Poettering 2007-09-25 00:22:32 UTC
Fixed in 0.6.21-6 which I just commited to Rawhide.


Note You need to log in before you can comment on or make changes to this bug.