Bug 27936 - X11 failure on a SGI 1200 box with GD5480
Summary: X11 failure on a SGI 1200 box with GD5480
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-16 05:41 UTC by Steve Dum
Modified: 2007-04-18 16:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-19 16:52:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Dum 2001-02-16 05:41:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i686)


I've got a SGI 1200 machine with a Cirrus Logic GD5480 video card.
When I load fisher on it, all my windows end up with transparent
backgrounds
and window erase functions don't work.  As the window 'scrolls' it just
writes on top of the existing data.  Not useful at all.

7.0 loads and runs just fine on it, and it detects and configures the same
devices.

It looks like fisher is trying to run v4 drivers and 7.0 is loading v3
drivers.

Is there a way to force the installer or Xconfigurator to use
v3 or v4?



Reproducible: Always
Steps to Reproduce:
1. Just run Xconfigurator on SGI 1200 box with Cirrus Logic GD5480 video
card
2.
3.
	

Actual Results:  transparent windows, clear doesn't work, reset doesn't
clear screen

Comment 1 Glen Foster 2001-02-17 22:39:34 UTC
We (Red Hat) should really try to resolve this before next release.

Comment 2 Steve Dum 2001-02-22 23:36:54 UTC
Contrary to original statement - XFree86 v4 was also being used on Redhat 7.0.
So the server is working ok on this box with guinness and it is failing with
fisher.
Using XFree86_SVGA v3 server with fisher doesn't fix the problem either.

Comment 3 Steve Dum 2001-02-26 17:22:05 UTC
It would appear that the wolverine release did not resolve this problem.  I
upgraded the failing box
with the new XFree86 packages from wolverine and saw no change in behavior.
( I was unable to do a full reload because of kernel driver problems-- yet
another defect report.)

Comment 4 Mike A. Harris 2001-02-26 19:50:29 UTC
Please provide your Xserver logs and XF86config-4 files as bug attachments
from the server you are having problems with.

Also, try with the "no_accel" option.

Comment 5 Preston Brown 2001-02-28 03:01:54 UTC
our test box with a GD5480 works here with both drivers...Mike, please try and
determine what has changed in this driver since 7.0.  It could be a compiler
issue if you find nothing.

Comment 6 Steve Dum 2001-02-28 05:21:56 UTC
I thought I added a comment earlier, but its not here
so one more time...
In trying to get  the log files, I reran Xconfigurator.
after doing that the problem went away.  I believe I
didn't rerun Xconfigurator after upgrading to wolverine,
so it looks like this is fixed with wolverine.

Comment 7 Mike A. Harris 2001-03-19 05:03:31 UTC
Ok, it looks like you got it going ok now.  Can you confirm this works ok,
so I can close the bug?

TIA

Comment 8 Steve Dum 2001-03-19 16:52:01 UTC
confirmed - fixed in 2nd beta.


Note You need to log in before you can comment on or make changes to this bug.