Bug 279471 - ath5k does not work properly on Alienware M7700 laptop
ath5k does not work properly on Alienware M7700 laptop
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-05 17:18 EDT by Jason
Modified: 2008-08-19 14:36 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-19 14:36:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages entries after 'modproble ath5k' (3.65 KB, application/octet-stream)
2007-10-18 01:15 EDT, Satish Balay
no flags Details

  None (edit)
Description Jason 2007-09-05 17:18:07 EDT
Description of problem:
ath5k does not work properly on Alienware M7700 laptop.

Version-Release number of selected component (if applicable):
Current kernel is kernel-2.6.23-0.164.rc5.fc8, have no had success with prior 
two kernels either.

How reproducible:
Boot F8T1 and attempt to use ath5k to connect to wireless network.

Steps to Reproduce:
1. Boot laptop
2. Attempt to connect to wireless network using ath5k
3. Try to browse websites
  
Actual results:
The driver does enable the adapter to connect to the wireless access point, 
obtain an ip address, and ping websites by name, however browsing websites is 
almost impossible. I can get to www.google.com, and some other very small 
websites, however virtually anything else is inaccessible.

Expected results:
Should be able to access websites, etc normally.

Additional info:
The card information (as output from lspci -vv) is:
0a:05.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC 
(rev 01)
        Subsystem: Wistron NeWeb Corp. CM9 Wireless a/b/g MiniPCI Adapter
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 168 (2500ns min, 7000ns max), Cache Line Size: 128 bytes
        Interrupt: pin A routed to IRQ 20
        Region 0: Memory at b3010000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [44] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME
(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=2 PME-

The wireless access point is a Netgear WGR614v6 running firmware 
V2.0.19_1.0.19NA, using WEP encryption.

I actually had no success using madwifi-ng-current snapshot from 2007-09-03; 
results were similar although I was unable to ping websites, etc. If I did not 
specify a static IP address the connection would fail after the dhcp client 
timed out.

madwifi-ng-current snapshot from 2007-08-29 works well, or at least appears to. 
I can access all network resources I've tried connecting to normally.
Comment 1 John W. Linville 2007-09-13 13:18:00 EDT
FWIW, it sounds like ath5k is working better for you than for most...
Comment 2 John W. Linville 2007-09-28 10:11:16 EDT
kernel-2.6.23-0.212.rc8.git2.fc8 contains some ath5k updates.  Can you 
replicate with that kernel?
Comment 3 Jason 2007-09-30 11:51:44 EDT
If anything it is worse, after a long pause it picks up an IP Address but it 
then attempts to ping the gateway, gets the error message 

4 packets transmitted, 0 received, +1 errors, 100% packet loss, time 3011ms, 
pipe 4
External network device wlan0 is not ready. Aboring..
 failed.

and of course after that the interface is down.

Once again using the madwifi-ng driver all I do is 'sudo make clean && sudo 
make && sudo make install', change modprobe.conf to read from 'alias wlan0 
ath5k' to 'alias wlan0 ath_pci'

I also have to rename the ath5k module to something like ath5k.bak, because 
regardless of what modprobe.conf says it tries to load the ath5k driver rather 
than ath_pci at boot. Not sure why, but it doesn't seem right...

After those three steps everything works as expected (using madwifi-ng)
Comment 4 Satish Balay 2007-10-05 12:50:46 EDT
I have a Thinkpad T40 with Atheros AR5211.

I've noticed that ath5k [from fredora kernel] never worked - but madwifi-0.9.3.2
- compiled from sources, always worked. This is with 'ifup ath0' - and not
NetworkManager.

I've checked with a bunch of rawhide kernels [perhaps over the past 2-3 weeks -
but not since FC8T3 was released]

Perhaps this is the same issue - hence monitoring this bugzilla.
Comment 5 Satish Balay 2007-10-05 13:15:28 EDT
Additional Notes:

Current kernel I have is 2.6.23-0.217.rc9.git1.fc8

I just tried without encryption [ a different network] - and 'ifup ath0' succeeds. 

However 'NetworkMonitor applet' says signal strength is 0%. iwconfig gives:
          Link Signal level=36/127  
Madwifi - for the same netowrk [where 'NetworkMonitor shows proper signal] gives:
          Link Quality=27/70  Signal level=-71 dBm  Noise level=-98 dBm


The network where I have constant problem with ath5k connecting is my home
network - with a 64bit WEP key
Comment 6 John W. Linville 2007-10-05 13:29:31 EDT
If you have the ath_info binary from the madwifi package, it may be worthwhile 
for you to post the information it provides.  IIRC, you have to run lspci 
first to determine the base address assigned to your card by the BIOS, then 
pass that as an argument to ath_info.
Comment 7 Satish Balay 2007-10-05 14:32:17 EDT
Looks like ath_info is in the svn copy - not 0.9.3.2. I've updated madwifi to
svn for now.

I'm not sure if I'm doing this incorrectly. I get:
# lspci |grep Ath
02:02.0 Ethernet controller: Atheros Communications, Inc. AR5211 802.11ab NIC
(rev 01)
# ath_info 02:02.0
Mmap of device at 0x00000002 for 0x10000 bytes failed - Invalid argument

I've also tried 'lspci -vv'
02:02.0 Ethernet controller: Atheros Communications, Inc. AR5211 802.11ab NIC
(rev 01)
        Subsystem: Unknown device 17ab:8310
        Flags: bus master, medium devsel, latency 168, IRQ 11
        Memory at c0210000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [44] Power Management version 2

# ath_info c0210000
Unable to read EEPROM Magic value !
Comment 8 John W. Linville 2007-10-05 14:50:24 EDT
# ath_info 0xc0210000

Try that?  (Note the "0x".)
Comment 9 Satish Balay 2007-10-05 15:01:28 EDT
ok - I get:

# ./tools/ath_info 0xc0210000
 -==Device Information==-
MAC Version:  5211 (0x40) 
MAC Revision: 5211 (0x42) 
5Ghz PHY Revision: 5111 (0x17) 
2Ghz PHY Revision: 2111 (0x23) 
 -==EEPROM Information==-
EEPROM Version:     3.2 
EEPROM Size:        16K
Regulatory Domain:  0x61 
 -==== Capabilities ====-
|  802.11a Support: yes  |
|  802.11b Support: yes  |
|  802.11g Support: no   |
|  RFKill  Support: no   |
 ========================
GPIO registers: CR 00000003 DO 00000000 DI 00000004
Comment 10 Jason 2007-10-06 22:03:49 EDT
 -==Device Information==-
MAC Version:  5212  (0x50) 
MAC Revision: 5213  (0x59) 
PHY Revision: 5112a (0x36) 
 -==EEPROM Information==-
EEPROM Version:     4.8 
EEPROM Size:        16K
Regulatory Domain:  0x0 
 -==== Capabilities ====-
|  802.11a Support: yes  |
|  802.11b Support: yes  |
|  802.11g Support: yes  |
|  RFKill  Support: yes  |
|  32KHz   Crystal: yes  |
 ========================

Completely fails with an non-upgraded F8T3 install
(kernel-2.6.23-0.214.rc8.git2.fc8) It doesn't even pretend to act like it is
going to connect, just flat out fails. Using madwifi-ng once again works.
Comment 11 Jason 2007-10-06 23:27:01 EDT
kernel-2.6.23-0.220.rc9.git2.fc8 is back to the previous behaviour:

4 packets transmitted, 0 received, +1 errors, 100% packet loss, time 3011ms, 
pipe 4
External network device wlan0 is not ready. Aboring..
 failed.
Comment 12 John W. Linville 2007-10-16 16:08:37 EDT
There are some ath5k updates in the kernels here:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=21169

YMMV, I get an (apparently) different oops now...

Do these kernels make a difference for you?
Comment 13 Satish Balay 2007-10-18 01:15:46 EDT
Created attachment 230681 [details]
/var/log/messages entries after 'modproble ath5k'
Comment 14 Satish Balay 2007-10-18 01:19:18 EDT
Sorry - my previous message was incomplete.

The previously attached log is with kernel-2.6.23.1-16.fc8. Here 'ifup ath0'
continues to not work with ath5k driver [wep 64bit, dhcp]. However it works fine
with madwifi-0.9.3.2
Comment 15 John W. Linville 2007-10-19 17:55:18 EDT
FYI, info on how to help the ath5k reverse engineering team:

   http://marc.info/?l=linux-wireless&m=119282415503974&w=2
Comment 16 John W. Linville 2007-11-09 15:47:49 EST
Please try the kernels here:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=23734

Are these working any better for you?
Comment 17 Chuck Ebbert 2007-11-09 17:37:45 EST
On my Aspire notebook, I don't get any errors and there is now a wlan0 interface
where there wasn't one before. But NM doesn't see any wireless networks...
Comment 18 Satish Balay 2007-11-09 19:58:25 EST
No change for me. i.e

- WEP64 does not work.
- no-encryption works[with 'NetworkMonitor applet' showing no signal strenth]
Comment 19 Satish Balay 2007-12-04 00:53:18 EST
Good news.

I just tried 2.6.23.9-78.fc8 from
http://koji.fedoraproject.org/koji/buildinfo?buildID=26543

WEP64 finally works with ath5k [with my limited testing]

However 'NetworkMonitor applet' continues to show no signal strength

[Note: I'm not using NetworkManager]

Comment 20 Satish Balay 2007-12-05 11:55:10 EST
I still have problems with ath5k & kernel-2.6.23.9-78.fc8]

When I move from a WEP64 network to encryption=off network. it stops working.
[i.e 'ifup wifi0' fails].

I've tried the following:
- reload ath5k module - same behavior
- reboot- same behavior
- reboot to 2.6.23.8-63.fc8 - same behavior
- unload ath5k and load ath_pci [in 2.6.23.8-63.fc8], now it works!
- unload ath_pci and load ath5k [still in 2.6.23.8-63.fc8] - it works!
- reboot to 2.6.23.9-78.fc8 - it works!

This happened twice [yesterday, and now today]. I guess I should stay with
madwifi for some more time.

BTW: wrt "nm-applet not showing signal strength with ath5k", should I file a
different bug report? [I'm guessing this is a problem with ath5k driver - as
this applet works fine with madwifi]
Comment 21 Jon Stanley 2008-01-16 19:39:22 EST
Satish -

Yes, please file a separate bug report on the signal strength problem in
nm-applet.  Also, can you please try a later kernel?
Comment 22 Satish Balay 2008-01-18 10:59:28 EST
Ok - I've retried with kernel-2.6.23.14-111.fc8

- The problem with moving between networks persist [between WEP64 and
encryption=off]. I was able to reset the behavior by either booting into windows
- or loading madwifi [rebooting with ath5k didn't help]

Wrt nm-applet - its behaving better. i.e, I'm able to see the signal strength
properly now.

However there is still one issue. When the network is down, [with ifdown wifi0]
- it still shows signal strength [with the a red x indicating that the network
is down though]. I don't know if this is acceptable behavior. With madwifi - the
signal strength is 0 after 'ifdown ath0'

iwconfig-after-ifdown-ath0:
 Link Quality=0/70  Signal level=-98 dBm  Noise level=-98 dBm
iwconfig-after-ifdown-wifi0:
 Link Quality=54/100  Signal level=-63 dBm  Noise level=-98 dBm

Because of the first issue [unable to switching between networks], ath5k is
still unusable to me. I'll continue to use madwifi.
Comment 23 John W. Linville 2008-01-18 11:18:50 EST
Does the "moving between networks" issue happen when using manual 
configuration (i.e. iwconfig, iwlist, etc) too?  Or only with NetworkManager?

The ath5k driver should be using software encryption (i.e. done at the CPU, 
not on the card itself), so it doesn't make much sense that the problem should 
survive a reboot.
Comment 24 Satish Balay 2008-01-18 12:14:35 EST
I primarily use ifup/ifdown with
/etc/sysconfig/network-scripts/ifcfg-ath0,ifcfg-wifi0 config files

[And I haven't used NM in a while because it didn't work predictably for me -
when I tried using it.]

Wrt reboot not resetting settings - I'm guessing that its not the enc-settings
per-say - but some bad state the hardware goes into or something.

So far I tried switching between 'wep64-> enc-off' and 'enc-off -> wep-64'. Both
failed. [I tried reboot/winxp reset only between 'wep64-> enc-off' transition].
However I suspect the problem might be there when switching between any two
networks - irrespective of encryption. [I don't have access to enough networks
to try...]

Perhaps someone else with a Thinkpad T40 [with atheros] can try reproducing this
problem.
Comment 25 John W. Linville 2008-01-18 16:43:28 EST
Could you attach the contents of your ifcfg-* files?  Feel free to obscure 
your WEP keys as you desire.
Comment 26 Satish Balay 2008-01-18 17:02:04 EST
Contents of /etc/sysconfig/network-scripts/ifcfg-wifi0

>>>>>>>>>>>>
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
IPV6INIT=no
ONBOOT=no
USERCTL=no
PEERDNS=no
TYPE=Wireless
DEVICE=wifi0
HWADDR=
BOOTPROTO=dhcp
NETMASK=255.255.255.0
DHCP_HOSTNAME=
DOMAIN=
CHANNEL=1
MODE=Managed
RATE=0kb/s

ESSID=xxxx
<<<<<<<

Contents of /etc/sysconfig/network-scripts/keys-wifi0
>>>
KEY=xxxx
<<<

---------------------------------------------------------

When switching networks - I just modify keys-wifi0 with both
ESSID,KEY fields updated.
Comment 27 Stephen 2008-03-02 18:25:32 EST
ath5k fails to load on my Z60t:

$ dmesg

...
ACPI: PCI Interrupt 0000:13:00.0[A] -> GSI 19 (level, low) -> IRQ 21
PCI: Setting latency timer of device 0000:13:00.0 to 64
ath5k_pci 0000:13:00.0: registered as 'phy0'
ath5k phy0: failed to resume the MAC Chip
ACPI: PCI interrupt for device 0000:13:00.0 disabled
ath5k_pci: probe of 0000:13:00.0 failed with error -5
...



$ lspci -nvv

13:00.0 Ethernet controller [0200]: Atheros Communications, Inc. AR5212
802.11abg NIC [168c:1014] (rev 01)
	Subsystem: IBM ThinkPad 11a/b/g Wireless LAN Mini Express Adapter (AR5BXB6)
[1014:058a]
	Flags: fast devsel, IRQ 21
	Memory at a7f00000 (64-bit, non-prefetchable) [disabled] [size=64K]
	Capabilities: <access denied>
	Kernel modules: ath_pci, ath5k


madwifi from livna works on this machine. It looks like this:

$ modprobe ath_pci

ath_hal: module license 'Proprietary' taints kernel.
ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
wlan: 0.8.4.2 (0.9.3.3)
ath_pci: 0.9.4.5 (0.9.3.3)
ACPI: PCI Interrupt 0000:13:00.0[A] -> GSI 19 (level, low) -> IRQ 21
PCI: Setting latency timer of device 0000:13:00.0 to 64
ath_rate_sample: 1.2 (0.9.3.3)
wifi0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps
36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
wifi0: mac 10.3 phy 6.1 radio 10.2
wifi0: Use hw queue 1 for WME_AC_BE traffic
wifi0: Use hw queue 0 for WME_AC_BK traffic
wifi0: Use hw queue 2 for WME_AC_VI traffic
wifi0: Use hw queue 3 for WME_AC_VO traffic
wifi0: Use hw queue 8 for CAB traffic
wifi0: Use hw queue 9 for beacons
wifi0: Atheros 5212: mem=0xa7f00000, irq=21


$ sudo ./ath_info 0xa7f00000
Warning: Invalid EEPROM Magic number!
 -==Device Information==-
MAC Version:  2424  (0xa0)
MAC Revision: 5424  (0xa3)
5Ghz PHY Revision: SChip (0xa2)
2Ghz PHY Revision: SChip (0xa2)
 -==EEPROM Information==-
EEPROM Version:     5.3
EEPROM Size:        4K
Regulatory Domain:  0x62
 -==== Capabilities ====-
|  802.11a Support: yes  |
|  802.11b Support: yes  |
|  802.11g Support: yes  |
|  RFKill  Support: yes  |
|  32KHz   Crystal: no   |
 ========================
GPIO registers: CR 0001800f DO 00000003 DI 0000000b


$ rpm -q kernel
kernel-2.6.23.14-115.fc8

Comment 28 John W. Linville 2008-03-04 14:22:53 EST
Stephen, I have copied the information from comment 27 to bug 254192 comment 
96.  Please direct your attention there...thanks!
Comment 29 John W. Linville 2008-06-04 14:55:55 EDT
OK, it's been a while...is this still a problem with current F8 (or F9) kernels?
Comment 30 Satish Balay 2008-06-04 15:49:31 EDT
I've upgraded to a machine with intel 3945ABG - so I can't test this anymore..
Comment 31 Stephen 2008-06-06 09:21:23 EDT
I've been trying F8 updates, with no joy.

Just tried F9 and it works! At least, it does for a simple unencrypted connection.

Progress!
Comment 32 John W. Linville 2008-07-08 16:09:01 EDT
Are current kernels working to your satisfaction?
Comment 33 John W. Linville 2008-08-19 14:36:30 EDT
Closed due to lack of response...

Note You need to log in before you can comment on or make changes to this bug.