Bug 279501 - Unable to install update-testing version of wine
Unable to install update-testing version of wine
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-05 17:20 EDT by Bill C. Riemers
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-05 18:09:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill C. Riemers 2007-09-05 17:20:56 EDT
Description of problem:

I am attempting to install the latest development/testing version of wine, but
it seems the dependency tree is broken.

[root@hartnell yum.repos.d]# yum update wine
fedora                    100% |=========================| 2.1 kB    00:00     
updates                   100% |=========================| 1.9 kB    00:00     
freshrpms                 100% |=========================| 1.9 kB    00:00     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: glibc-headers = 2.6-4 for package: glibc-devel
--> Processing Dependency: glibc-headers = 2.6-4 for package: glibc-devel
---> Package glibc.x86_64 0:2.6.90-13 set to be updated
--> Processing Dependency: glibc-common = 2.6.90-13 for package: glibc
---> Package wine.i386 0:0.9.44-1.fc8 set to be updated
--> Processing Dependency: wine-cms = 0.9.44-1.fc8 for package: wine
--> Processing Dependency: wine-jack = 0.9.44-1.fc8 for package: wine
--> Processing Dependency: wine-tools = 0.9.44-1.fc8 for package: wine
--> Processing Dependency: wine-core = 0.9.44-1.fc8 for package: wine
--> Processing Dependency: wine-esd = 0.9.44-1.fc8 for package: wine
--> Processing Dependency: wine-capi = 0.9.44-1.fc8 for package: wine
--> Processing Dependency: wine-nas = 0.9.44-1.fc8 for package: wine
--> Processing Dependency: wine-ldap = 0.9.44-1.fc8 for package: wine
--> Processing Dependency: wine-twain = 0.9.44-1.fc8 for package: wine
---> Package glibc-headers.x86_64 0:2.6.90-13 set to be updated
---> Package glibc.i686 0:2.6.90-13 set to be updated
--> Running transaction check
---> Package glibc-common.x86_64 0:2.6.90-13 set to be updated
--> Processing Dependency: wine-core = 0.9.43-3.fc7 for package: wine-devel
---> Package wine-ldap.i386 0:0.9.44-1.fc8 set to be updated
---> Package wine-jack.i386 0:0.9.44-1.fc8 set to be updated
---> Package wine-nas.i386 0:0.9.44-1.fc8 set to be updated
---> Package wine-esd.i386 0:0.9.44-1.fc8 set to be updated
---> Package wine-tools.i386 0:0.9.44-1.fc8 set to be updated
---> Package wine-twain.i386 0:0.9.44-1.fc8 set to be updated
---> Package wine-capi.i386 0:0.9.44-1.fc8 set to be updated
---> Package wine-cms.i386 0:0.9.44-1.fc8 set to be updated
---> Package glibc-devel.x86_64 0:2.6.90-13 set to be updated
---> Package wine-core.i386 0:0.9.44-1.fc8 set to be updated
--> Running transaction check
---> Package wine-devel.i386 0:0.9.44-1.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 wine                    i386       0.9.44-1.fc8     development        19 k
Updating for dependencies:
 glibc                   x86_64     2.6.90-13        development       4.8 M
 glibc                   i686       2.6.90-13        development       5.4 M
 glibc-common            x86_64     2.6.90-13        development        18 M
 glibc-devel             x86_64     2.6.90-13        development       2.4 M
 glibc-headers           x86_64     2.6.90-13        development       592 k
 wine-capi               i386       0.9.44-1.fc8     development        23 k
 wine-cms                i386       0.9.44-1.fc8     development        36 k
 wine-core               i386       0.9.44-1.fc8     development       9.3 M
 wine-devel              i386       0.9.44-1.fc8     development       2.1 M
 wine-esd                i386       0.9.44-1.fc8     development        33 k
 wine-jack               i386       0.9.44-1.fc8     development        35 k
 wine-ldap               i386       0.9.44-1.fc8     development        85 k
 wine-nas                i386       0.9.44-1.fc8     development        21 k
 wine-tools              i386       0.9.44-1.fc8     development       593 k
 wine-twain              i386       0.9.44-1.fc8     development        44 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update      16 Package(s)         
Remove       0 Package(s)         

Total download size: 44 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package glibc-devel needs glibc = 2.6-4, this is not available.
Package glibc-devel needs glibc-headers = 2.6-4, this is not available.
Package glibc-devel needs glibc-headers = 2.6-4, this is not available.
Package glibc-devel needs glibc = 2.6-4, this is not available.
Complete!
Comment 1 Ignacio Vazquez-Abrams 2007-09-05 17:36:23 EDT
updates-testing and development are 2 separate repositories. It appears you're
trying to install wine from development, whereas the bug title makes it sound as
though you want the updates-testing version instead.

But in any case, it looks like the problem is a multilib issue with glibc.
Comment 2 Bill C. Riemers 2007-09-05 18:09:23 EDT
Thanks,  that was the problem.  I was trying to install updates-testing, but I
accidentally enabled development instead.

Note You need to log in before you can comment on or make changes to this bug.