Bug 279931 - [ja] sazanami-fonts-gothic not included in stage2.img
[ja] sazanami-fonts-gothic not included in stage2.img
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-09-05 22:02 EDT by Jens Petersen
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 22:02:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2007-09-05 22:02:19 EDT
Description of problem:
When doing an installation of current rawhide, anaconda does not
seem to be using outline fonts when installing in Japanese -
it seems to be using a bitmap font from fonts-japanese instead AFAICT.

Version-Release number of selected component (if applicable):
anaconda-11.3.0.26-1

How reproducible:
every time

Steps to Reproduce:
1. do a (net) install of current rawhide (20070905)
2. choose Japanese for languages
3. goto gui installer
4. inspect stage2.img

Actual results:
3. glyphs are rendered in bitmap fonts
4. no sazanami fonts

Expected results:
3. text should be rendered in truetype fonts as usual
4. should have /usr/share/fonts/sazanami

Additional info:
This is may be because of recent changes in fonts-japanese
where the sazanami fonts were moved out of fonts-japanese.
Comment 1 Jeremy Katz 2007-09-06 15:19:34 EDT
Yep, that would be it.  Fixed in CVS
Comment 2 Jens Petersen 2007-09-06 21:58:32 EDT
Thanks.

BTW now cjkunifonts-* were split out of fonts-chinese too if that matters.

If you don't mind I would rather keep this open until it is fixed in rawhide.
I will close it once I can check the fix.
Comment 3 Jens Petersen 2007-09-17 22:05:06 EDT
This still seems to happen in current rawhide.
Comment 4 Jens Petersen 2007-09-17 22:14:03 EDT
Loop mount stage2.img shows:

% ls usr/share/fonts/
arabic   cjkunifonts-uming  gujarati  kannada  malayalam  punjabi  tamil
bengali  dejavu-lgc         hindi     korean   oriya      sinhala  telugu

So the new cjkunifonts-uming is there but not sazanami-fonts-gothic.
Comment 5 Jeremy Katz 2007-09-18 14:59:13 EDT
Would help if I typed the path right.  Fixed in CVS
Comment 6 Jens Petersen 2007-09-20 22:02:36 EDT
Thanks!  Confirmed fixed in current rawhide.

Note You need to log in before you can comment on or make changes to this bug.