Bug 279941 - Qt doesn't follow the decoration on preediting
Qt doesn't follow the decoration on preediting
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
bzcl34nup
: i18n
Depends On:
Blocks: 218399
  Show dependency treegraph
 
Reported: 2007-09-05 22:11 EDT by Jens Petersen
Modified: 2008-05-01 19:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-01 19:17:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 1 Jens Petersen 2007-09-05 22:12:49 EDT
Here is the original description:

Description of problem:
When you type the Hangul, underline appears in preedit.  However it doesn't
appear at the bottom of the letter but 5~10% up from the bottom where I expected
it to appear.

For Hangul, underline in preedit interferes with input since it is one letter
at a time.  Indeed Windows(ime2002) doesn't use underline for Hangul either.

How reproducible:
always

Steps to Reproduce:
1. run gedit and increase the font size
2. activate the scim-hangul
3. type"rnr" <--"?"
  
Actual results:
Preedit has underline towards bottom of preedit which is confusing.

Expected results:
No underline for Hangul.
Comment 2 Bug Zapper 2008-04-04 09:46:39 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 3 Jens Petersen 2008-04-14 21:56:12 EDT
Yes this seems to be fixed with qt4. :)
Comment 4 John Poelstra 2008-05-01 19:09:18 EDT
re: comment #3 should this bug be closed?

Note You need to log in before you can comment on or make changes to this bug.