Bug 280101 - generated anaconda-ks.cfg %packages differs from %packages in kickstart
generated anaconda-ks.cfg %packages differs from %packages in kickstart
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Martin Sivák
Milan Zazrivec
:
: 235454 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-06 03:46 EDT by Alexander Todorov
Modified: 2008-05-21 11:31 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0397
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:31:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 227383 None None None Never

  None (edit)
Description Alexander Todorov 2007-09-06 03:46:03 EDT
Description of problem:
Using ks.cfg containing
------------------
%packages
@Everything
------------------
or
------------------
%packages
*
------------------

produces anaconda-ks.cfg containing @core, @base and some other packages,
which doesn't recreate the same system. Number of installed packages is 2098.

Performing manual install and customizing the packages selection in GUI works as
expected. Right clicking with the mouse and selecting "All
optional packages" for every group leads to anaconda-ks.cfg file that recreates
the same system when used for subsequent install.

All installs are with latest RHEL5.1-Server-20070905.nightly tree, not using
installation key (Server repo only).

Version-Release number of selected component (if applicable):
anaconda-11.1.2.72-1

How reproducible:
Always

Steps to Reproduce:
1. Use a kickstart file for installation containing @Everything(*) in the
packages section.
2. Complete the install and get the generated anaconda-ks.cfg
3. Both kickstart files should contain the same packages section.
4. Both kickstart files should lead to the same set of installed packages.
(Re-install with anaconda-ks.cfg to retest).
  
Actual results:
anaconda-ks.cfg generated when using @Everything:
https://bugzilla.redhat.com/attachment.cgi?id=187291

Expected results:
generated anaconda-ks.cfg contains the same packages section as used kickstart
during installation.

Additional info:
Manual selection of packages seem to work correctly. See Bug #227383
Comment 1 Chris Lumens 2007-09-06 09:57:05 EDT
Created attachment 188781 [details]
use input %packages section for anaconda-ks.cfg

This may need a little tweaking because pykickstart in RHEL5 is significantly
different from the one in rawhide.
Comment 2 Chris Lumens 2007-09-11 16:03:21 EDT
*** Bug 235454 has been marked as a duplicate of this bug. ***
Comment 4 RHEL Product and Program Management 2007-10-15 23:42:06 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Milan Zazrivec 2008-02-06 10:31:03 EST
Verified with RHEL5.2-{Client,Server}-20080206.nightly / anaconda-11.1.2.96-1
Comment 8 errata-xmlrpc 2008-05-21 11:31:43 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0397.html

Note You need to log in before you can comment on or make changes to this bug.