Bug 28013 - Custom update/package group install needed
Custom update/package group install needed
Status: CLOSED DUPLICATE of bug 10930
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-16 13:57 EST by Greg Corson
Modified: 2014-03-16 22:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-17 15:38:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Corson 2001-02-16 13:57:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


When doing a custom install you are offered up many "package groups" like 
the Apache, Samba or Network Management groups which contain a number of 
RPM packages.  Once you have done an install, there seems to be no method 
to go back and load one of these groups, the packages have to be loaded 
individually.

Reproducible: Always
Steps to Reproduce:
1.Do an install (say, "laptop")
2.decide you want to have the complete samba server package group added to 
your install two days later
3.How do you go about it?  "Update install" seems to only allow you to 
pick individual packages rather than package groups.
	

It would be VERY useful to have a way to go back and install a complete 
package group after the fact.  Figuring out all the packages that need to 
be installed to get a full and working Apache or Samba install is much 
harder than just hitting "apache group" on the custom installer.

Currently, if you go back and do an "update" install you have to do things 
one package at a time.  Or am I missing something?
Comment 1 Michael Fulbright 2001-02-20 14:28:44 EST
There is definately the need for a tool to let you add package groups after the
install. I think this is going to best addressed by a userland tool, and not as
part of the installer.
Comment 2 Greg Corson 2001-02-20 15:23:57 EST
If nothing else, could the lists of what's included in each of the package 
groups be published on the redhat website?  That would make it easier to 
manually install the right stuff after the fact.

It's clear that some packages are more up-to-date and usable than others, in 
general some commentary from RedHat on the state of the packages (or at least 
the ones you have tested) would be useful so you don't install something that's 
out of date or incompatible with the current kernal by accident.
Comment 3 Michael Fulbright 2001-09-17 15:37:07 EDT
Reassigning to the distribution component.
Comment 4 Brent Fox 2002-06-04 23:20:35 EDT

*** This bug has been marked as a duplicate of 10930 ***

Note You need to log in before you can comment on or make changes to this bug.