Bug 280191 - fencing agents should be broken out into sub-packages
fencing agents should be broken out into sub-packages
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: fence (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Fabio Massimo Di Nitto
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-06 05:27 EDT by David Juran
Modified: 2010-12-21 11:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-09 05:10:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Juran 2007-09-06 05:27:48 EDT
Description of problem:
cman contains a lot of fencing agents, all of which have their own set of
dependencies, e.g. as discussed in Bug 189668 fence-ilo depends on
perl-Crypt-SSLeay. Chris Feist pointed out that adding all these dependencies to
the cman package isn't really viable since that would add a huge chain of
dependencies to satisfy all the agents while a typical installation only uses
one or two of those. It might be better (as suggested by Bryn) to break out each
fencing agent into it's own (sub)-package and give each sub-package it's own set
of dependencies. 

Version-Release number of selected component (if applicable):
cman-2.0.60-3.fc7

How reproducible:
[root@localhost ~]# /sbin/fence_ilo 
Net::SSL.pm or Net::SSLeay::Handle.pm not found.
Please install the perl-Crypt-SSLeay package from RHN (http://rhn.redhat.com)
or Net::SSLeay from CPAN (http://www.cpan.org)
Comment 1 Bryn M. Reeves 2007-09-06 05:38:11 EDT
My only thought against this is that it complicates manual installation of a
cluster environment (need to know about and then install the correct agents).
Since the users will need to configure an appropriate agent anyway it's maybe
not that big a deal.

Although having full dependencies declared will easy life for those with highly
automated deploy environments that rely on yum/anaconda to pull in all needed
packages.
Comment 2 Bryn M. Reeves 2007-09-06 05:39:04 EDT
Also, shouldn't this be filed against the fence component rather than cman?
Comment 3 Bryn M. Reeves 2007-09-06 06:56:42 EDT
corrected component
Comment 4 Bug Zapper 2008-04-04 09:46:50 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 5 David Juran 2008-04-15 07:37:56 EDT
I guess there is no consensus on whether the fencing agents really should be
broken out or not but to answer the comment above, all of the agents still are
in cman-2.0.60-5 so I'm changing the version back to rawhide. 
Comment 6 Bug Zapper 2008-05-13 23:11:54 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Fabio Massimo Di Nitto 2008-05-22 23:23:34 EDT
Hi guys,

i don't think it is wise to break fence agents in their own subpackages. I agree
that there a bunch of extra dependencies to install (not that many anymore) but
we have no easy way to tell our users what fence agents they will need to
install and it will make the installation and deployment one step more complicated.

I'd like to close this one as WONTFIX.

Fabio
Comment 8 Fabio Massimo Di Nitto 2008-06-09 05:10:06 EDT
No comments in about 20 days. Closing as suggested (WONTFIX). Please reopen if
you want to discuss the issue further.

Fabio
Comment 9 Vladislav Bogdanov 2010-12-21 11:21:21 EST
Hi,

what about introducing meta-package which depends on all fence-agents subpackages and is installed by default? By groups mechanism f.e.
Also every fence-agent subpackage could introduce virtual "feature", on which cman could depend.

I mean:
fence-agents (meta)
Require: fence-agent-1 fence-agent-2 fence-agent-3 ...

fence-agent-1
Provides: fence-agent

fence-agent-2
Provides: fence agent

cman
Requires: fence-agent

anaconda
Group(Cluster): cman, fence-agents

This way X drivers are packaged I assume.
Comment 10 Fabio Massimo Di Nitto 2010-12-21 11:35:30 EST
(In reply to comment #9)
> Hi,
> 
> what about introducing meta-package which depends on all fence-agents
> subpackages and is installed by default? By groups mechanism f.e.
> Also every fence-agent subpackage could introduce virtual "feature", on which
> cman could depend.
> 
> I mean:
> fence-agents (meta)
> Require: fence-agent-1 fence-agent-2 fence-agent-3 ...

At the stage in which fence agents are now developed upstream, this is an overkill and useless process. It could have been (maybe) a gain few years back when this bug was initially discussed, but with today's code it is a pointless and very expensive operation.

Note You need to log in before you can comment on or make changes to this bug.