Bug 28033 - uptdate thinks that a *new* re-install does not need any updates.
uptdate thinks that a *new* re-install does not need any updates.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-16 14:40 EST by Elton Woo
Modified: 2015-01-07 18:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-19 20:33:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elton Woo 2001-02-16 14:40:53 EST
After a fresh, *new* re-install of Fisher, up2date reports no updates
needed.
I had registered anomymously during the first install, and updates were
installed.  However, since this was a clean re-install, shouldn't the
system
database report that is not in sync with available fixes?
Comment 1 Adrian Likins 2001-02-17 22:21:12 EST
There are currently no updated packages available in the anonymous 
up2date server that Fisher talks to by default. So detecting
that no new packages are available for a client fisher install is
the correct behaviour.

I'm more interested in why up2date would have detected there
were packages available for update in the first install. Was
this an upgrade from 7.0? Were any packages downgraded manually?
Comment 2 Elton Woo 2001-02-18 03:45:20 EST
No, the initial install was a clean (freshly formatted system) installation of
the Fisher beta. 
At that time, I installed almost everything, merely to be sure that I had all
needed libraries.
After the RHN configuration, I ran RHN update, and sure enough, I got a long
list of 
available updates, of which I selected almost all.

I decided to do a fresh install, selecting only have the applications which I am
more likely
to use, or which (IMHO), I might be more capable of detecting any "buggy"
behavoir. Unlike
the first install, I also added some apps and libraries from the Power Tools CD.

Subsequently, when I run the RHN config. and update,  it reports that my system
is fully updated.

If you wish, I could do *yet another* fresh install, and test if up2date reports
any available stuff. Now
that I've replaced my old 16x Toshiba with an Acer 12x DVD (40x CDR),
installation goes a bit faster on my AMD-k2/500. Though I don't have a backup
tape device, I can easily copy / save
my own data to the Windows98 partition or onto my LS-120 diskettes.
Comment 3 Cristian Gafton 2001-02-19 20:33:28 EST
Assigned QA to jturner
Comment 4 Preston Brown 2001-02-20 12:37:49 EST
the fact that packages were available the first time must have been a transient
server configuration issue -- no updates were made available for fisher via
RHN.  This may change.  However, the current behaviour (no updates available) is
expected.

Note You need to log in before you can comment on or make changes to this bug.